[foxfooding] Time is often wrong after reboot

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: smaug, Unassigned)

Tracking

({foxfood})

unspecified
ARM
Gonk (Firefox OS)
foxfood

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-master unaffected)

Details

(Reporter)

Description

3 years ago
Often after reboot time is wrong, and to set it again switching set-time-automatically off and back on and rebooting seems to help (but perhaps just rebooting would help too).
(Reporter)

Updated

3 years ago
Keywords: foxfood
Can you please find if this is a duplicate and close this?

Thanks
Keywords: qawanted
I can't reproduce this bug on today's Aries. I have a SIM and Wifi connected, time set to my timezone during FTU (it should not have shown timezone selection during FTU when I have a SIM, but SIM detection have been slow in past months), and after reboot (several times) it still showed the right time.

Leaving qawanted for others to attempt.

Device: Aries 2.5
BuildID: 20151006110922
Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
Gecko: 89732fcdb0baca70e8b7a25a2725117113f0db80
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Flags: needinfo?(jmercado)
(Reporter)

Comment 3

3 years ago
Just retested on foxfooding (Sony) phone. I live in Finland so it should be ~2:10am here, but after reboot phone has time 11:10 pm (yesterday). Rebooting again doesn't help, but going into the settings and switching off Set_Automatically time and setting it back on and reboot helps.
Did you set your timezone correctly? So that enabling 'Set Automatically' will auto set the time for you?

Also, what is your build ID?

We have a lot of time related bugs currently open, but none that reproduces in the way that you described (maybe).
Flags: needinfo?(jmercado)
(Reporter)

Comment 5

3 years ago
Timezone can be set manually only when Set_Automatically is off, and yes, it is right, Europe/Helsinki (UTC+3)
Could you set the time back to 'set auto' AFTER you have set the correct timezone, and then reboot and see if time is correct?

Do you have a SIM as well as internet connection?

Also when you see time wrong the next time, could you go into Clock app and see if time is correct there?
(Reporter)

Comment 7

3 years ago
I do have a SIM and I use only 3G/4G data connection, not wifi with the phone.
(In Finland 3G/4G data plans are unlimited and rather cheap and 4G works almost everywhere, so there isn't really need for wifi use.) 


Setting time manually and then enabling automatic time and rebooting seems to give the right time.
If I then keep Set_Automatically on and reboot, the time is again wrong.
(Reporter)

Comment 8

3 years ago
And now after latest FOTA update the situation is even worse. After switching off and on the automatic time and rebooting, time is correct for awhile, but then it changes and is wrong.

Going into the settings and switching automatic update off and back on helps.
(Reporter)

Comment 9

3 years ago
Definitely worse now (managed to oversleep today because of this).
The easiest way to reproduce here is to
- open Settings->Date&Time
- switch off and off 'Set automatically' (time is now right)
- swipe from top and switch on flight mode (the airplane icon)
- switch off flight mode
- Time becomes right time - 3h.
(Reporter)

Updated

3 years ago
Severity: normal → critical
(Reporter)

Comment 10

3 years ago
(In reply to Olli Pettay [:smaug] from comment #9)
> Definitely worse now (managed to oversleep today because of this).
> The easiest way to reproduce here is to
> - open Settings->Date&Time
> - switch off and off 'Set automatically' (time is now right)
off and on
[Blocking Requested - why for this release]:

QAnalysts, Can you confirm the build its being reproduced on?

Olly - Can you please attach logs?

Nominating as 2.5 blocker

Thanks
blocking-b2g: --- → 2.5?
QA Whiteboard: [foxfood-triage]
(In reply to Olli Pettay [:smaug] from comment #0)
> Often after reboot time is wrong, and to set it again switching
> set-time-automatically off and back on and rebooting seems to help (but
> perhaps just rebooting would help too).

Hi Olli, Can you Please provide your exact REPRO Steps, because so far, I cannot Repro this issue, 
and the Automatic mode is already bugged, and is a known issue. 

STR: 
1) Flash Aries to latest build. 
2) Upon Restart, set the time manually to the correct time, zone, and date. 
3) Restart the Device, and observe the Time, Zone and Date. 
4) Set the time to Automatic, Restart the Device. 
5) Observe that the Time, Zone and Date.  

NO REPRO per these builds when using these Steps: 

RESULT: 
When set time manually upon starting the phone, restarting (reboot), setting to automatic and restarting the phone again, the time, date, and zone remain correct .

Environmental Variables:
Device: Aries 2.5
BuildID: 20151019104907
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: d3e87bb40753327550143ba8ac8ee27b300cd4a9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20150922115027
Gaia: 68361828ae88dffd04b250121b5f2472a63f4bf0
Gecko: a1ccea59e254a88f7bb44b0ad8a58b77b7eca339
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [foxfood-triage] → [foxfood-triage][QAnalyst-Triage?]
status-b2g-master: --- → unaffected
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Contact: sleedavid
Olli if you could also provide your build variables that would be useful.  QA has seen a lot of issues where the automatic time incorrectly uses a wrong timezone that can be fixed/broken again by manually changing the timezone to be correct/incorrect and renabling automatic time.  However if that is the problem you are seeing we aren't unerstanding that and there are actually multiple bugs already made on this issue.  

Mahendra we have not reproduced this issue as we understand it so we cannot confirm what build it reproduces on.
QA Whiteboard: [foxfood-triage][QAnalyst-Triage?] → [foxfood-triage][QAnalyst-Triage+]
Flags: needinfo?(jmercado)
(Reporter)

Comment 14

3 years ago
STR: 
1) Flash Aries to latest build. 
2) Upon Restart, set the time manually to the correct time, zone, and date. 
3) Restart the Device, and observe the Time, Zone and Date. 
4) Set the time to Automatic, Restart the Device. 
5) Observe that the Time, Zone and Date. 

after (3) time is correct.
at (5) time is correct for a short while after pin check, and then time is set to be 3 hours too early (so UTC+0).

Aries
BuildNumber eng.naoki.20151007.074137
BuildID 20151019102225
(Reporter)

Comment 15

3 years ago
I'm using the default dogfooding builds. Just updated OTA, and the issue is still there.
Is there some way to debug the time-setting sequence?  Could smaug's cellular network be sending something we don't expect?

Gregor, who knows about time-related things these days?
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(anygregor)
Dave, do you happen to have some cycles?
Or maybe Ken has someone that can help out?
Flags: needinfo?(kchang)
Flags: needinfo?(dhylands)
Flags: needinfo?(anygregor)

Comment 18

3 years ago
Samael, can this bug be fixed by your solution on bug 1209892?
Flags: needinfo?(kchang) → needinfo?(sawang)
Gregor - I'm trying to reproduce, but the settings app crashes as soon as I touch Date & Time (using latest master). Sigh.
Flags: needinfo?(dhylands)
(In reply to Dave Hylands [:dhylands] from comment #19)
> Gregor - I'm trying to reproduce, but the settings app crashes as soon as I
> touch Date & Time (using latest master). Sigh.

I guess you are seeing bug 1192189.
debug version of the app crashes.
non-debug seems to work fine.

I don't have a SIM in my phone and it seems to work properly whether on Auto or Not after a reboot.
(In reply to Dave Hylands [:dhylands] from comment #21)
> debug version of the app crashes.
> non-debug seems to work fine.
> 
> I don't have a SIM in my phone and it seems to work properly whether on Auto
> or Not after a reboot.

Just a note I also tried to reproduce this on a nightly aries-eng build and I could not reproduce. I tried both with an without a SIM. Wifi was on. As soon as I change back to automatic (step 4 above), the correct time is shown. Rebooting doesnt change it. Also setting an incorrect time, and leaving automatic off, the incorrect time i set stays set.
(In reply to Ken Chang[:ken] from comment #18)
> Samael, can this bug be fixed by your solution on bug 1209892?

If you're noticing automatic timezone bring you to UTC+0, it's highly possible to be related to bug 1209892. Comment 14 looks so to me. We should keep track after the solution for bug 1209892 landed.
Flags: needinfo?(sawang)
(Reporter)

Comment 24

3 years ago
Note, I'm not using wifi connection, always 3G/4G connection.

And I'll test this again once bug 1209892 lands.
Until that, keeping 'Set automatically' off seems to at least prevent
random time changes.

Comment 25

3 years ago
I run into the same problem after flashing my flame to the latest nightly build 2.5.

Step to reproduce 1.
Before reboot: data is on, automatic time setting is off, time is 10:37, date is 26.10.2015
After reboot: data is on, automatic time setting is off, time is 03:48, date is 29.01.2015

Step to reproduce 2.
Before reboot: data is off, automatic time setting is off, time is 10:44, date is 26.10.2015
After reboot: data is off, automatic time setting is off, time is 03:52, date is 29.01.2015

24-hours time format used.
(In reply to Olli Pettay [:smaug] from comment #24)
> Note, I'm not using wifi connection, always 3G/4G connection.
> 
> And I'll test this again once bug 1209892 lands.
> Until that, keeping 'Set automatically' off seems to at least prevent
> random time changes.

We've phased-in the solution of bug 1209892 today. Would you like to build an image with latest code and give it a try?
(In reply to Artem Polivanchuk from comment #25)
> I run into the same problem after flashing my flame to the latest nightly
> build 2.5.
> 
> Step to reproduce 1.
> Before reboot: data is on, automatic time setting is off, time is 10:37,
> date is 26.10.2015
> After reboot: data is on, automatic time setting is off, time is 03:48, date
> is 29.01.2015
> 
> Step to reproduce 2.
> Before reboot: data is off, automatic time setting is off, time is 10:44,
> date is 26.10.2015
> After reboot: data is off, automatic time setting is off, time is 03:52,
> date is 29.01.2015
> 
> 24-hours time format used.

Is that a typo or seriously your device date changed to 29.01.2015? That's too surprising.

Comment 28

3 years ago
Nope, it's not a typo.
As you can see, I've ran this test during filling the bug.
I flashed the fresh 2.5 yesterday and now date is going to be set to 01.02.2015 each time after reboot :)
(In reply to Artem Polivanchuk from comment #28)
> date is going to be set to 01.02.2015 each time after reboot :)

This sounds hardware RTC failure to me. Does "adb shell dmesg | grep -i rtc" show anything irregular?
This is a regular output with my flame-kk, BTW:

> $ dmesg | grep -i rtc
> [    0.181609] RTC time:  2:47:10, date: 10/22/15
> [    0.553439] rtc_cmos 00:02: RTC can wake from S4
> [    0.553553] rtc_cmos 00:02: rtc core: registered rtc_cmos as rtc0
> [    0.553577] rtc_cmos 00:02: alarms up to one month, y3k, 242 bytes nvram, hpet irqs
> [    0.564535] rtc_cmos 00:02: setting system clock to 2015-10-22 02:47:11 UTC (1445482031)

Comment 31

3 years ago
(In reply to Samael Wang [:freesamael][:sawang] from comment #29)
> (In reply to Artem Polivanchuk from comment #28)
> > date is going to be set to 01.02.2015 each time after reboot :)
> 
> This sounds hardware RTC failure to me. Does "adb shell dmesg | grep -i rtc"
> show anything irregular?

I'll be able to check this some later today from my home pc.
On Flame, it's known and won't be fixed (see bug 1069863 and duplicates).

Let's focus on the possible bug in Aries here please.
(In reply to Olli Pettay [:smaug] from comment #24)
> Note, I'm not using wifi connection, always 3G/4G connection.
> 
> And I'll test this again once bug 1209892 lands.
> Until that, keeping 'Set automatically' off seems to at least prevent
> random time changes.

Hi Olli, have you tried if the fix of bug 1209892 helps?
Flags: needinfo?(bugs)
(Reporter)

Comment 34

3 years ago
bug 1209892 is not yet in any (F)OTA, right? I use Aries as my main phone, so would prefer to not
test local builds.
Flags: needinfo?(bugs)

Updated

3 years ago
Component: General → Gaia::System
Not sure why it was changed to Gaia::System if all the time/date related changes are deep in Gonk...
Component: Gaia::System → General

Updated

3 years ago
Component: General → GonkIntegration
(Reporter)

Comment 36

3 years ago
Got just an (F?)OTA update and so far haven't managed to reproduce this bug anymore.
Thanks smaug! Lets reopen if it shows up again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.