incorrect positioning of OMTA-transform-animated element

RESOLVED DUPLICATE of bug 1206418

Status

()

RESOLVED DUPLICATE of bug 1206418
3 years ago
3 years ago

People

(Reporter: heycam, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox43+, firefox44+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8664611 [details]
test

With OMTA turned on, the animation in this attachment sometimes places the <div> at the very top of the page and sometimes places at its original vertical position.  When I jiggle the mouse around, I can get this effect, but if I leave the mouse alone for a while it settles in to its expected vertical position.

I can reproduce this on both my Linux and OS X machine.
(Reporter)

Comment 1

3 years ago
Created attachment 8664612 [details]
video showing the problem
(Reporter)

Comment 2

3 years ago
Last good revision: 7641104770a80015e63597b58cb312fefcbd9ab4
First bad revision: 621ab19e86db28c38bbbf9119fbf6831ea344c54
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7641104770a80015e63597b58cb312fefcbd9ab4&tochange=621ab19e86db28c38bbbf9119fbf6831ea344c54

Which just has bug 1097464.  Thinker, is this likely to be a dupe of bug 1206418?
Blocks: 1097464
Flags: needinfo?(tlee)
[Tracking Requested - why for this release]:  Web compatibility regression
tracking-firefox43: --- → ?
tracking-firefox44: --- → ?

Comment 4

3 years ago
Cameron, right!  There are several dupe of this bug.  I will open a new bug and dup all other bugs.
Flags: needinfo?(tlee)
I'll track this for now. If it's a duplicate, please mark it as such!
status-firefox43: --- → affected
tracking-firefox43: ? → +
tracking-firefox44: ? → +

Comment 6

3 years ago
Created attachment 8666434 [details] [diff] [review]
Improve GetBounds() to avoid recomputing every time

Updated

3 years ago
Attachment #8666434 - Attachment is obsolete: true

Updated

3 years ago
Depends on: 1206418
No longer blocks: 1097464
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox43: affected → ---
status-firefox44: affected → ---
No longer depends on: 1206418
Resolution: --- → DUPLICATE
Duplicate of bug: 1206418
You need to log in before you can comment on or make changes to this bug.