Drop a link on tab bar doesn't work

RESOLVED FIXED in mozilla44

Status

()

Core
Drag and Drop
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: Krzysztof, Assigned: Neil Deakin)

Tracking

({regression})

41 Branch
mozilla44
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 affected, firefox42 affected, firefox43 affected, firefox44 unaffected, firefox-esr38 unaffected)

Details

(Whiteboard: [dupe me])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150831030209

Steps to reproduce:

1. Open new page in a text editor (Notepad++).
2. Past there any link, for instance http://goo.gl, then select this link.
3. Try to drag&drop this link on a tab bar, between tabs (as a new tab) or on any tab. 


Actual results:

I see an up-arrow icon (this doesn't dissapear) and a crossed circle. The link is not opening. 


Expected results:

The link should have been opened.
(Reporter)

Updated

2 years ago
Version: 40 Branch → 41 Branch

Comment 1

2 years ago
Yes, I filed a similar bug (bug 1207634) with details. Surely a dupe.
Component: Untriaged → Drag and Drop
Product: Firefox → Core

Comment 2

2 years ago
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=44986f66ee4b&tochange=8c81e97e0604

Regressed by: Bug 1121946
Blocks: 1121946
Status: UNCONFIRMED → NEW
status-firefox41: --- → affected
status-firefox42: --- → affected
status-firefox43: --- → affected
status-firefox44: --- → unaffected
status-firefox-esr38: --- → unaffected
Ever confirmed: true
Keywords: regression
Whiteboard: [dupe me]

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207634

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 4

2 years ago
Created attachment 8677492 [details] [diff] [review]
Don't set dropEffect or effectAllowed when dropping tabs

I originally posted an earlier version of this patch in bug 1207634.

This issue here is that the drag data only allows 'move' and 'copy' but the tabbar sets the drop effect to 'link'. 'link' is intended to be used to create a link to the original data which perhaps is an abstract way of thinking about dropping links onto the tabbar, but other applications don't seem to think that way. So this patch doesn't set the dropEffect or effectAllowed within the dragover event.
Assignee: nobody → enndeakin
Status: REOPENED → ASSIGNED
(Assignee)

Updated

2 years ago
Attachment #8677492 - Flags: review?(dao)

Updated

2 years ago
Attachment #8677492 - Flags: review?(dao) → review+
(Assignee)

Updated

2 years ago
Blocks: 1207634
(Assignee)

Comment 5

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/dcd16953417bee8297fbd412a0654b63c3e98b5d
Bug 1207594, don't set dropEffect and effectAllowed in tab bar dragover event, which allows drops of data that aren't links, r=dao

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/dcd16953417b
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44

Updated

a year ago
Depends on: 1235129
You need to log in before you can comment on or make changes to this bug.