[E10s] Ensure that drop effect is updated properly on Windows

RESOLVED FIXED in Firefox 41

Status

()

Core
Drag and Drop
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: smaug, Assigned: Neil Deakin (not available until Aug 9))

Tracking

36 Branch
mozilla41
x86_64
Windows
Points:
1
Dependency tree / graph

Firefox Tracking Flags

(e10sm7+, firefox41 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
With the latest patch for bug 936092 drop effect works properly on Linux only.
(Reporter)

Updated

3 years ago
Blocks: 1121947
(Reporter)

Updated

3 years ago
No longer blocks: 1121947

Updated

3 years ago
tracking-e10s: --- → m7+

Comment 1

3 years ago
Does this impact web compat, or is it purely cosmetic?
Flags: needinfo?(bugs)
(Reporter)

Comment 2

3 years ago
I'm just updating the patch for bug 936092  so that this should be just cosmetic.
Depends on: 936092
Flags: needinfo?(bugs)
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1158518
(Reporter)

Comment 4

2 years ago
but even if mostly cosmetic, something to fix.
I'm not at all familiar with Windows widget layer, so someone who is should take a look.

Updated

2 years ago
Assignee: nobody → jmathies

Updated

2 years ago
OS: Linux → Windows
Created attachment 8614160 [details] [diff] [review]
Windows version of the patch in 1121947
Assignee: jmathies → enndeakin
Status: NEW → ASSIGNED
The patch here depends on some platform independent stuff from the the patch in 1121947.
Depends on: 1121947
Attachment #8614160 - Flags: review?(jmathies)
One more thing: it looks like this wasn't ever fully implemented in Windows, so this patch also fixes that to make the feedback cursor correct.

Updated

2 years ago
Attachment #8614160 - Flags: review?(jmathies) → review+
Points: --- → 1

Comment 8

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8c81e97e0604
https://hg.mozilla.org/mozilla-central/rev/8c81e97e0604
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41

Updated

2 years ago
Depends on: 1207634

Updated

2 years ago
Depends on: 1207594
Duplicate of this bug: 484511

Updated

a year ago
Depends on: 1256162
You need to log in before you can comment on or make changes to this bug.