Creating new folder for bookmarks in sidebar from context menu assigns given name to last item on same level like new folder

RESOLVED DUPLICATE of bug 1206376

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 1206376
2 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(firefox41 affected, firefox42- affected, firefox43 affected, firefox44 unaffected)

Details

Firefox 41.0, Firefox 42.0b1, Aurora 20150922, not on Nightly 20150923 on Windows 8.1 64 bit

Creating a new bookmarks folder from the context in the bookmarks sidebar assigns the given name to the last item on same level like the new folder.

Steps to reproduce:
1. Create new profile.
2. Open bookmarks sidebar (Ctrl + B).
3. Open the folder 'Bookmarks Menu'
4. Open the folder 'Mozilla Firefox'.
5. Right click on the second bookmark and choose 'New folder'.
The bookmark dialog doesn't get focus (this also affects Nightly).
6. Type in a name and confirm the dialog.
Actual result:
New folder created, by name assigned to last (= fourth) bookmark.

[Tracking Requested - why for this release]:
People will rename existing bookmarks without noticing it and get confused.
This also affects the bookmarks manage if the user right-clicks in the upper right pane for creating a new bookmark.
See Also: → bug 1208063

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1206376
Not tracking, we are already tracking the other.
tracking-firefox42: ? → -
You need to log in before you can comment on or make changes to this bug.