[Mac only] Web page scrolls when scrolling through hello conversations or contacts list

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

({regression})

Trunk
All
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox44 affected)

Details

Attachments

(1 attachment)

Affected builds:
- latest Nightly 44.0a1
- latest Developer Edition 43.0a2

Unable to reproduce with Firefox 42beta1

Affected OS`s:
- Mac OS X 10.10.5

STR:
1. Start Firefox
2. Visit a page that can be scrolled
3. Click Hello icon
4. Open many conversations until scrollbar appears in Hello panel
5. Scroll through conversations

Expected results: The webpage does not scroll when scrolling through hello conversations.

Actual results: Scroll keeps bouncing between webpage and hello conversations list.

Notes:
1. This is a regression

m-c

Last good Nightly: 2015-07-22
First bad Nightly: 2015-07-23

Last good revision: 8e5c888d0d89
First bad revision: 1f77b78797d6

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8e5c888d0d89&tochange=1f77b78797d6

m-i

Last good revision: 6ad92b48085b5ec5532f14e0b9e3c5eb15ad9fa8
First bad revision: cfc312d8ef205bcb6a58b840459a4ccd922dcf88

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ad92b48085b5ec5532f14e0b9e3c5eb15ad9fa8&tochange=cfc312d8ef205bcb6a58b840459a4ccd922dcf88

Probably caused by this bug:

cfc312d8ef20 Kartikaya Gupta — Bug 1157746 - Enable APZ on OS X desktop nightly builds. r=mstange
Created attachment 8665855 [details]
Screencast showing the issue
Flags: needinfo?(bugmail.mozilla)

Updated

3 years ago
Duplicate of this bug: 1208379
I'm not able to repro on the latest nightly on OS X but it looks pretty bad.
Blocks: 1178298
Flags: needinfo?(bugmail.mozilla)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)
> Affected builds:
> - latest Nightly 44.0a1
> - latest Developer Edition 43.0a2

Actually this is odd since 43.0a2 should have APZ disabled by default.

> Affected OS`s:
> - Mac OS X 10.10.5

This might be relevant; I'm running 10.9.5.
Just checked on 10.9.5 and I can reproduce there as well.
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #5)
> Just checked on 10.9.5 and I can reproduce there as well.

Does this still happen on the latest nightly? I'm curious if this was fixed by bug 1190112.

And if it happens on Firefox 43, do you happen to have layers.async-pan-zoom.enabled turned on in about:config?
Flags: needinfo?(bogdan.maris)
(In reply to David Anderson [:dvander] from comment #6)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #5)
> > Just checked on 10.9.5 and I can reproduce there as well.
> 
> Does this still happen on the latest nightly? I'm curious if this was fixed
> by bug 1190112.
> 
> And if it happens on Firefox 43, do you happen to have
> layers.async-pan-zoom.enabled turned on in about:config?

Here are the results of the testing:

- latest Developer Edition 43.0a2 (buildID: 20151009004029):
-- layers.async-pan-zoom.enabled - false (default) - NOT reproducible
-- layers.async-pan-zoom.enabled - true - Reproducible

- latest Nightly 44.0a1 (buildID: 20151009030230):
-- layers.async-pan-zoom.enabled - false - NOT reproducible
-- layers.async-pan-zoom.enabled - true (default) - Reproducible

So indeed it does reproduce only if I have 'layers.async-pan-zoom.enabled' set as 'true'.
Flags: needinfo?(bogdan.maris) → needinfo?(dvander)
Are you still able to reproduce this? The Hello UI appears to have been updated and it looks different now.
Flags: needinfo?(bogdan.maris)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> Are you still able to reproduce this? The Hello UI appears to have been
> updated and it looks different now.

Nope, the issue seems fixed to me, with layers.async-pan-zoom.enabled true or false. I will close it as worksforme.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bogdan.maris)
Resolution: --- → WORKSFORME
Thanks!
Flags: needinfo?(dvander)
Again I see this in Firefox 47 beta 7 with hello version 1.3.2. 'layers.async-pan-zoom.enabled' set to 'true' (by default) and 'false'. Do you think it could be something from Hello side?

Running on Mac OS X 10.10.5
Flags: needinfo?(bugmail.mozilla)
If it's only happening on OS X and not other platforms it's most likely something in Gecko. But if it happens with both APZ on and off then it's not a result of APZ. If you can consistently reproduce we can open a new bug and try to track it down.
Flags: needinfo?(bugmail.mozilla)
See Also: → bug 1281413
You need to log in before you can comment on or make changes to this bug.