Unship service workers and push notifications in Firefox 42

VERIFIED FIXED

Status

()

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

({dev-doc-complete})

unspecified
dev-doc-complete
Points:
---

Firefox Tracking Flags

(firefox42 fixed, firefox43 unaffected, relnote-firefox 42+)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Since we aren't shipping push in 42, there is no reason to support service workers.
(Assignee)

Comment 1

3 years ago
Created attachment 8666110 [details] [diff] [review]
Unship service workers in Firefox 42
Attachment #8666110 - Flags: review?(nsm.nikhil)
Comment on attachment 8666110 [details] [diff] [review]
Unship service workers in Firefox 42

Review of attachment 8666110 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/app/profile/firefox.js
@@ +1949,2 @@
>  // Enable Push API.
>  pref("dom.push.enabled", true);

Also this this in that case, since without serviceworkers, push is useless.
Attachment #8666110 - Flags: review?(nsm.nikhil) → review+
Dev-doc-needed to update MDN's compat tables.
Keywords: dev-doc-needed
(Assignee)

Comment 4

3 years ago
Comment on attachment 8666110 [details] [diff] [review]
Unship service workers in Firefox 42

Approval Request Comment
Service workers and push will not ship on 42.  This patch disables them.

Note that this will only land on beta.
Attachment #8666110 - Flags: approval-mozilla-beta?
(Assignee)

Updated

3 years ago
See Also: → bug 1203324
status-firefox42: --- → affected
status-firefox43: --- → unaffected
Comment on attachment 8666110 [details] [diff] [review]
Unship service workers in Firefox 42

ok, let's disable it.

Ehsan, we had "Ship Push messaging with disabled web notifications from ServiceWorkers" in the release notes, I guess we should remove it, right?
Flags: needinfo?(ehsan)
Attachment #8666110 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 6

3 years ago
(In reply to Sylvestre Ledru [:sylvestre] from comment #5)
> Ehsan, we had "Ship Push messaging with disabled web notifications from
> ServiceWorkers" in the release notes, I guess we should remove it, right?

Yes please.  I'm setting the relnote flag as a reminder.
relnote-firefox: --- → ?
Flags: needinfo?(ehsan)
(Assignee)

Comment 7

3 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/0b0bb745a61a
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Summary: Unship service workers in Firefox 42 → Unship service workers and push notifications in Firefox 42
Removed from the 42 beta release notes!
relnote-firefox: ? → 42+
If I understand well here, this means that SW and Push API will be enable by default in Fx 43 (unless the same patch that has been applied here to Fx 42 Beta is applied to Fx 43 when it will reach beta)

[If this happens, will it happens here or in another bug?]
Flags: needinfo?(sledru)
Exactly.

If this happens again, it might be in this bug or in a new bug (sorry about that).
We will try to update this bug if this happens in another bug.
Flags: needinfo?(sledru)
What is the the problem in having SW without push nofications? SW is useful even without it.
(Assignee)

Comment 12

3 years ago
(In reply to Arthur Stolyar [:nekr] from comment #11)
> What is the the problem in having SW without push nofications? SW is useful
> even without it.

Our service worker implementation can only deal with fetch and push events, neither of which are available in 42.  Without those two, service workers are useless.
I've verified this bug landed in Fx42b4
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1207875

Comment 15

3 years ago
(In reply to Jean-Yves Perrier [:teoli] from comment #9)
> If I understand well here, this means that SW and Push API will be enable by
> default in Fx 43 (unless the same patch that has been applied here to Fx 42
> Beta is applied to Fx 43 when it will reach beta)
> 
> [If this happens, will it happens here or in another bug?]

See bug 1215230
Again, see bug 1215230 for updates on SW compat info.
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.