Closed Bug 1208704 Opened 5 years ago Closed 5 years ago

a big gap between symbol/menu row and calendar on large screens

Categories

(Calendar :: Calendar Frontend, defect)

Lightning 4.3
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hornig, Assigned: ssitter)

References

Details

Attachments

(4 files)

Attached image gap.png
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150917150946

Steps to reproduce:

open the calendar, maximize on screens with 1440 pixel high


Actual results:

there is a big gap in the user interface above the caendar


Expected results:

no gap on big screens
Component: Theme → Calendar Views
Product: Thunderbird → Calendar
Version: 41 → Lightning 4.3
Do you have any error messages in the log (ctrl+shift+j)? Where the gap is, the find events bar is usually located. I guess you have the Find Events entry enabled in Events and Tasks menu? What is your OS?
1) there are no error message triggert when the calendar starts.
2) I researched and found the "find events and task", it opens at the same place, it let me change the size of the gap. But when I extend it to max height ( 1440px) it opens again from aprox 1280px on. If the "find event..." is switched on, the size does not change with the windows height. If it is switched off, the gap gets bigger with higher window height.
3) My OS is Windows 8.1


while I wrote this, suddenly this error came up in the console many times:
Zeitstempel: 03.10.2015 11:53:40
Fehler: TypeError: this.tree is null
Quelldatei: chrome://calendar/content/calendar-unifinder.js
Zeile: 502
Zeitstempel: 03.10.2015 11:53:40
Fehler: [Exception... "[JavaScript Error: "this.tree is null" {file: "chrome://calendar/content/calendar-unifinder.js" line: 502}]'[JavaScript Error: "this.tree is null" {file: "chrome://calendar/content/calendar-unifinder.js" line: 502}]' when calling method: [calIObserver::onLoad]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1222"  data: yes]
STACK: notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1222:17
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1228:9
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:464:16
calCompositeCalendarObserverHelper.prototype.onLoad@file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:44:13
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1222:17
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1228:9
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:464:16
calICSObserver.prototype.onLoad@file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js:842:9
ics_onParsingComplete@file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js:289:17
ip_processIcalComponent/<@resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calIcsParser.js:108:17
parserState.prototype.checkCompletion@resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calIcsParser.js:317:13
run@resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calIcsParser.js:294:17

Quelldatei: resource://calendar/modules/calUtils.jsm -> file:///P:/e-MailProfil/a47epujn.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Zeile: 1225
Attached image gap1.png
gap dissapear with "find event..." on
Attached image gap2.png
the gap re-appears after "find..." is switched off
Comment on attachment 8666321 [details]
gap.png

on verg large screen it is possible to open a gap in the calendar
Confirmed. I noticed this today using Lightning 4.6a2 + Thunderbird 44.0a2 (20151103004130) and screen resolution 1920x1080. The area is maybe 20 pixel large and in my case translucent, i.e. you can see the content of the windows behind the Thunderbird window. I did not noticed this previously when using Lightning 4.5a2 + Thunderbird 43.0a2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Does it happen in task view too?

I can't test with such resolutions but I'm wondering if the missing attribute flex="1" in the box id="calendar-view-box" [1], compared to the box id="calendar-task-box" [2] (both children of the deck calendarDisplayDeck), makes any difference. 

[1] http://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-views.xul#20
[2] http://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-task-view.xul#28
According to DOM Inspector the 'gap' was inside modevbox element with id="calendar-toolbox-container" / id="task-toolbox-container" but not inside the contained toolbox element. Removing the flex attribute seem to help in my case.

Decathlon, could you test the patch? To reproduce the problem I changed my screen resolution from landscape format to portrait format to get enough screen height to see the problem.
Attachment #8696460 - Flags: feedback?(bv1578)
Comment on attachment 8696460 [details] [diff] [review]
1208704-calendar-tab-gap.diff

(In reply to Stefan Sitter from comment #8)

> Decathlon, could you test the patch? To reproduce the problem I changed my
> screen resolution from landscape format to portrait format to get enough
> screen height to see the problem.

Ahh, yes, now I can easily reproduce the issue with the resolution 768 x 1366. I've never set a portrait format for the screen.

The bug is my fault, I introduced it with the patch for bug 1162380. The modevboxes don't have to have the flex attribute because the toolboxes inside have a fixed height.

Your patch fixes the issue for me. Thanks.
Attachment #8696460 - Flags: feedback?(bv1578) → feedback+
Comment on attachment 8696460 [details] [diff] [review]
1208704-calendar-tab-gap.diff

I tried to reproduce the problem in SeaMonkey 2.42a1 but it did not show the problem. Therefore this patch for Thunderbird seems sufficient.
Attachment #8696460 - Flags: review?(bv1578)
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Comment on attachment 8696460 [details] [diff] [review]
1208704-calendar-tab-gap.diff

I can reproduce with SeaMonkey 2.42a1 and Lightning 4.7a1. The gap is not transparent but it happens in the same way as with Thunderbird with the resolution 768 x 1366.

The patch also fixes the issue on SeaMonkey.

We should apply the patch on aurora and beta too.
Attachment #8696460 - Flags: review?(bv1578) → review+
Thank you for doing this.
My first bugzilla issue has been fixed by great code hero's!
Pushed to https://hg.mozilla.org/comm-central/rev/57bef2814968
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 4.7
Attachment #8696460 - Flags: approval-calendar-beta?(philipp)
Attachment #8696460 - Flags: approval-calendar-aurora?(philipp)
Blocks: 1162380
Guido, thank you for reporting the problem. Please keep testing beta builds and don't hesitate to report problems that you find.
Attachment #8696460 - Flags: approval-calendar-beta?(philipp)
Attachment #8696460 - Flags: approval-calendar-beta+
Attachment #8696460 - Flags: approval-calendar-aurora?(philipp)
Attachment #8696460 - Flags: approval-calendar-aurora+
Pushed to https://hg.mozilla.org/releases/comm-aurora/rev/24a4b4d87f23
Target Milestone: 4.7 → 4.6
Pushed to https://hg.mozilla.org/releases/comm-beta/rev/1423f97e1842
Target Milestone: 4.6 → 4.5
You need to log in before you can comment on or make changes to this bug.