Closed Bug 1208917 Opened 4 years ago Closed 4 years ago

VP8/9 decoding broken on ubuntu 15.04 with libav 11.2

Categories

(Core :: Audio/Video: Playback, defect)

43 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox43 --- fixed
firefox44 --- fixed

People

(Reporter: jya, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is a regression occurring due to bug 1207429.

When used with libav 11.2 ; we get a decoding error for either VP8 or VP9 codec.

Works fine with ffmpeg that ships with ubuntu 15.04 (libavcodec-ffmpeg)
Recent libav do not require a codec parser to decode VP9.
Attachment #8666540 - Flags: review?(ajones)
Attachment #8666540 - Flags: review?(ajones) → review+
https://hg.mozilla.org/mozilla-central/rev/06bcb0eaf47e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Blocks: 1214943
Comment on attachment 8666540 [details] [diff] [review]
Fix VP9 decoding with recent version of libav.

Approval Request Comment
[Feature/regressing bug #]:1197319, this is making FFmpeg code robust
[User impact if declined]: WeBM playback will fail if LibAV is installed instead of FFmpeg (which is the default on most linux distribution)
[Describe test coverage new/current, TreeHerder]: In central for a few weeks
[Risks and why]: Low, just testing that a particular API is supported and not just error
[String/UUID change made/needed]: None
Attachment #8666540 - Flags: approval-mozilla-aurora?
Comment on attachment 8666540 [details] [diff] [review]
Fix VP9 decoding with recent version of libav.

OK to uplift to aurora, adds a check for supported formats.
Attachment #8666540 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.