Crash in Client@0x{address}

RESOLVED DUPLICATE of bug 1207179

Status

()

--
critical
RESOLVED DUPLICATE of bug 1207179
3 years ago
3 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({crash})

unspecified
All
iOS
crash

Firefox Tracking Flags

(fxios-v1.1 fixed, fxios1.1+)

Details

(Reporter)

Comment 1

3 years ago
All the above reports seem to be from 1.1b1102, do we have the archive/symbols to take a dive into?
Needs symbols.
Flags: needinfo?(sleroux)
from brief google search

'EXC_BREAKPOINT most of the times tells you that you're referencing a symbol or framework which doesn't exist. That could be because the phone is jailbroken or because you say you're App is compatible with iOS version X but you're using frameworks/methods that are only available in more recent version. So check for that also.'

http://stackoverflow.com/questions/14769251/exc-breakpoint-crash-possible-jailbreak-issue/14797026#14797026
Ugh. So it turns out that the iOS 9 SDK now produces DWARF v4 debugging symbols instead of v3 and Breakpad's dump_syms utility only supports v2/v3. Since it's a relative new format (2010) there isn't any support for it yet in Breakpad. The other caveat is that the Breakpad team is focusing on a new tool called Crashpad that will act as the successor to Breakpad. Ted says they are still going to be using the utility tools from Breakpad but there doesn't seem to be any DWARF v4 planned yet so our symbols are essentially useless for now.
Flags: needinfo?(sleroux)
Flags: needinfo?(sleroux)
Finally got it symbolicated!:

https://bugzilla.mozilla.org/show_bug.cgi?id=1212021

Looks like it was crashing somewhere in the WKNavigation delegate didFinishNavigation but I'm not seeing any of these crashes in recent builds. Potentially an issue in this build only that got resolved? Hard to tell the exact cause since there are no line numbers...
Flags: needinfo?(sleroux)
Closing as WORKSFORME as it hasn't appeared in later builds.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Showed up as an EXC_BREAKPOINT in

https://crash-stats.mozilla.com/report/index/c863d1b9-aebf-45a8-beb8-58d6b2150922

with roughly the same stack.

(That was my own crash on that bug, FWIW.)
Ya this definitely seems like 1207179
status-fxios-v1.1: affected → fixed
tracking-fxios: ? → 1.1+
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1207179
You need to log in before you can comment on or make changes to this bug.