Closed Bug 1209167 Opened 4 years ago Closed 4 years ago

Firefox OS Add-ons landing page is 500ing

Categories

(Marketplace Graveyard :: Consumer Pages, defect, blocker)

x86
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: krupa.mozbugs, Assigned: mat)

References

Details

steps to reproduce:
1. Load marketplace-dev on your 2.5 device
2. Go to :debug page and click on Enable FxOS add-ons

expected behavior:
user is redirected to the fxos add-ons landing page which has add-ons listed

actual behavior:
user is redirected to the fxos add-ons landing page  which 500s.

09-28 14:03:29.054 I/Dev     (10017): Content JS LOG: [req] GETing https://marketplace-dev.allizom.org/api/v2/extensions/search/?_user=---&doc_type=all&lang=en-US&limit=10&region=us 
09-28 14:03:29.054 I/Dev     (10017):     at u/< (https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=1443460681:4:15844)
09-28 14:03:29.074 I/Dev     (10017): Content JS LOG: [navigation] Pushed state onto stack:  /addons 
09-28 14:03:29.074 I/Dev     (10017):     at u/< (https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=1443460681:4:15844)
09-28 14:03:29.334 W/Dev     (10017): [JavaScript Warning: "This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1." {file: "https://marketplace-dev.allizom.org/api/v2/extensions/search/?_user=kraj%40mozilla.com%2C7a9fcbf0ad345719042d50cf2eb469754ddff4e46895ddc39ccb04d7d607475615a965bf9aad109471e85044e41a7194050e189cb58c8ae2c4f1be3d75a34659%2C889a8432713147c4b22a28cfdde820f9&doc_type=all&lang=en-US&limit=10&region=us" line: 0}]
09-28 14:03:29.344 I/Dev     (10017): Content JS LOG: [req] Request failed: GET 500 
09-28 14:03:29.344 I/Dev     (10017):     at u/< (https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=1443460681:4:15844)
09-28 14:03:29.344 I/Dev     (10017): Content JS LOG: [req] Response data:  {"detail":"Internal Server Error"}
Assignee: nobody → dspasovski
500 should be fixed now, I've triggered another reindex (I had triggered one too early)
Assignee: dspasovski → mpillard
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.