Closed Bug 1209755 Opened 4 years ago Closed 4 years ago

[EME] Enable Adobe EME in official 64bit builds in Nightly, Aurora, and Beta

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla44
Tracking Status
firefox41 --- wontfix
firefox42 --- verified
firefox43 --- verified
firefox44 --- verified

People

(Reporter: cpearce, Assigned: cpearce)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Adobe are just about ready to give us a 64bit production EME CDM. So we should enable Adobe EME in official 64bit builds.
Attached patch PatchSplinter Review
Enable Adobe EME in 64bit official builds.
Attachment #8667634 - Flags: review?(mh+mozilla)
Attachment #8667634 - Flags: review?(mh+mozilla) → review+
Uplift needed.
Flags: needinfo?(cpearce)
Once we have a 64-bit Nightly build with working EME, we can ask coop to schedule 64-bit EME-free repacks in bug 1185105.
https://hg.mozilla.org/mozilla-central/rev/4823e6a7023c
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Comment on attachment 8667634 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: EME
[User impact if declined]: EME/Netflix won't work in Win64 Firefox
[Describe test coverage new/current, TreeHerder]: We have lots of EME mochitests.
[Risks and why]: Low; we already run this in Win32 Firefox.
[String/UUID change made/needed]: None.
Attachment #8667634 - Flags: approval-mozilla-beta?
Attachment #8667634 - Flags: approval-mozilla-aurora?
Comment on attachment 8667634 [details] [diff] [review]
Patch

Yeh! Increase the win 32/64 parity, taking it. should be in 42b3.
Attachment #8667634 - Flags: approval-mozilla-beta?
Attachment #8667634 - Flags: approval-mozilla-beta+
Attachment #8667634 - Flags: approval-mozilla-aurora?
Attachment #8667634 - Flags: approval-mozilla-aurora+
Flags: needinfo?(cpearce)
Flags: qe-verify+
QA Contact: alexandra.lucinet
Attached image ErrorMessageNetflix.png
Adobe EME is properly downloaded on 42.0b5 (Build ID: 20151008162217), latest 43.0a2 Aurora and 44.0a1 Nightly, under Windows 7 and Windows 10, 64-bit.

Two issues encountered after performing some additional exploratory testing:
1. When restarting Firefox while a video plays via Netflix, the attached error message is displayed (*note* that Netflix was running in one tab only); works after reloading the page though; I guess this could be due bug 925570?  
2. on Windows 10, I am unable to play any Netflix video on 43.0a2, 42 beta 5 and 6 - the loading state is displayed constantly, but it works with 44.0a1. Is this issue under your radar? Or do you have any idea what this could've fix it on latest Nightly? 

Thanks in advance, Chris!
Flags: needinfo?(cpearce)
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #12)
> Created attachment 8672963 [details]
> ErrorMessageNetflix.png
> 
> Adobe EME is properly downloaded on 42.0b5 (Build ID: 20151008162217),
> latest 43.0a2 Aurora and 44.0a1 Nightly, under Windows 7 and Windows 10,
> 64-bit.
> 
> Two issues encountered after performing some additional exploratory testing:
> 1. When restarting Firefox while a video plays via Netflix, the attached
> error message is displayed (*note* that Netflix was running in one tab
> only); works after reloading the page though; I guess this could be due bug
> 925570?  

Is that Nightly, and do you have e10s enabled? He had an issue with e10s enabled (bug 1186258), and also bug 1175317 at low volume.


> 2. on Windows 10, I am unable to play any Netflix video on 43.0a2, 42 beta 5
> and 6 - the loading state is displayed constantly, but it works with 44.0a1.
> Is this issue under your radar? Or do you have any idea what this could've
> fix it on latest Nightly? 
> 
> Thanks in advance, Chris!

Netflix have only enabled playback by default on Firefox Nightly 44. It's not enabled by default on Beta and Aurora channels. You can test on Beta/Aurora by overriding the navigator.useragent string using general.useragent.override pref.

Note: you don't need to test via beta.netflix.com anymore; you should be able to test on http://netflix.com now.
Flags: needinfo?(cpearce)
(In reply to Chris Pearce (:cpearce) from comment #13)
> (In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #12)
> > Created attachment 8672963 [details]
> > ErrorMessageNetflix.png
> > 
> > Adobe EME is properly downloaded on 42.0b5 (Build ID: 20151008162217),
> > latest 43.0a2 Aurora and 44.0a1 Nightly, under Windows 7 and Windows 10,
> > 64-bit.
> > 
> > Two issues encountered after performing some additional exploratory testing:
> > 1. When restarting Firefox while a video plays via Netflix, the attached
> > error message is displayed (*note* that Netflix was running in one tab
> > only); works after reloading the page though; I guess this could be due bug
> > 925570?  
> 
> Is that Nightly, and do you have e10s enabled? He had an issue with e10s
> enabled (bug 1186258), and also bug 1175317 at low volume.

Indeed only with e10s enabled, both Nightly and Aurora. This is applicable for both x32 and x64 builds. Unfortunately, I cannot access any of the given bugs.

> > 2. on Windows 10, I am unable to play any Netflix video on 43.0a2, 42 beta 5
> > and 6 - the loading state is displayed constantly, but it works with 44.0a1.
> > Is this issue under your radar? Or do you have any idea what this could've
> > fix it on latest Nightly? 
> > 
> > Thanks in advance, Chris!
> 
> Netflix have only enabled playback by default on Firefox Nightly 44. It's
> not enabled by default on Beta and Aurora channels. You can test on
> Beta/Aurora by overriding the navigator.useragent string using
> general.useragent.override pref.

Apparently, now it works - I guess it may have been a connection problem. Sorry for the noise. Also, it was Windows 10 only issue, it worked under Windows 7 64-bit with x64 Firefox builds. 

> Note: you don't need to test via beta.netflix.com anymore; you should be
> able to test on http://netflix.com now.

Thanks for sharing!

Marking accordingly since the remaining issue is not 64bit builds related.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.