Wrong order of messages if sorted by order received after compacting

RESOLVED DUPLICATE of bug 1183490
(NeedInfo from)

Status

RESOLVED DUPLICATE of bug 1183490
3 years ago
8 months ago

People

(Reporter: ppp, Unassigned, NeedInfo)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150925121647

Steps to reproduce:

I used to read emails while being ordered in "order received" (as I am using a german version, I don't know the exact english phrase; in german it is called "Eingangsreihenfolge").

To order emails this way, I click on the corresponding column header. In this columns are ascending numbers (I believe from observation that this is a byte-offset into the "Inbox" file).

Since about the last or second-last update (as delivered by linux mint repositories), it happens that new emails got a smaller number than that of the emails before. Therefore, this new emails aren't displayed at the "new" end of the list, because the order of the numbers is still displayed in ascending order.

After this happend the first time, I manually ordered the emails by moving them in the right order into a new folder, terminated thunderbird, removed Inbox and Inbox.msf manually, restarted thunderbird and moved the emails back to inbox. Then it worked for about two weeks, until today.

Today, thunderbird asked me if it should "compress" the folders (again, I don't know the correct english terms; I mean the process of getting rid of waste space occupied by deleted/moved away emails in folder-files). After then incoming emails aren't correctly ordered. I assume that after the "compressing" the byte-offsets changes, of course, but aren't updated in the inbox columns (even after restart of TB).

By guessing, now I tried to remove file "Inbox.msf" only. After restarting TB, .msf will be recreated and the order of emails has become correct again.


Actual results:

"compressing" folders changes byte offsets in folder-file (Inbox file) (naturally, as its file size shrinks meanwhile), but numbers in received-order-column isn't updated.

I think this is new since V38, because I used to display in "order received" for many years and also used to answer "yes" for many years if TB asks if it wants to "compress" the folders – without facing this problem before.


Expected results:

The displayed order should survive a "compressing" process, without the need of deleting .msf-file.
(Reporter)

Comment 1

3 years ago
I am using Linux Mint 17

$ uname -a
Linux pemu-ThinkPad-T540p 3.13.0-55-generic #92-Ubuntu SMP Sun Jun 14 18:32:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Thunderbird 38.2.0
(Reporter)

Comment 2

3 years ago
> Since about the last or second-last update (as delivered by linux mint repositories), it happens that new
> emails got a smaller number than that of the emails before.

I didn't mean that from this version on every new email is wrong ordered, but from this version on coincidently it may happen. (Back then, I hadn't pay attention, but I strongly believe that it was also after "compressing" folders.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1202516
(Reporter)

Comment 4

3 years ago
I’d rather say: duplicate of Bug 1183490, as stated there. Thanks for picking this.
(Reporter)

Updated

3 years ago
Duplicate of bug: 1183490

Comment 6

8 months ago
Peter, now that bug 1183490 is fixed, is your problem gone?
Flags: needinfo?(ppp)
Summary: Wrong order of messages if sorted by order received after compressing → Wrong order of messages if sorted by order received after compacting
You need to log in before you can comment on or make changes to this bug.