IMAP: folder summary not updated for new msgs

RESOLVED DUPLICATE of bug 18266

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED DUPLICATE of bug 18266
16 years ago
9 years ago

People

(Reporter: Mark Newby, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    2002011913

I'm submitting this on my Windows box, but this bug relates to me using Mozilla 
on Linux (RH7.2, 2.4.7-10).  This bug has been around for about the last 6mths 
worth of Mozilla releases...

For WU IMAP accounts (haven't tried POP or other IMAP server), when there's new 
messages in the remote mailbox file (eg from filtering mail on the IMAP server 
using procmail), the mailboxes (aka `folders') in the left-hand-side pane do 
not refresh themselves during/after send & receive.  Only when you actually 
click inside them do the new messages download and the summary update (ie name 
turns bold and unread msgs count updates).  I've been caught out by this many 
times, often missing important e-mails, as I had no idea they were sitting 
there.

Reproducible: Always
Steps to Reproduce:
These steps have only been tested against WU IMAP server (latest)...

1. make sure you've got a mailbox on the IMAP server (eg under the root IMAP 
folder) and you're `subscribed' to it in Mozilla M&N.
2. make a new message go into a mailbox on the IMAP server (eg using procmail 
to filter into this mailbox on the IMAP server).
3. use Mozilla Mail & News to send/receive/synch with this IMAP account (making 
sure you're *already* subscribed to this mailbox, as per step 1 above).
4. DO NOT click on this mailbox (aka `folder') in Mozilla M&N...yet.

Actual Results:  1. *without* clicking inside the folder representation of this 
mailbox, you'll see that the unread-messages-count has not been incremented and 
if this new message is the only new message in that mailbox, the folder name 
will not be made into a bold font, etc.  ie it's user interface is telling you 
there are no new messages in the mailbox after you've told it to get all new 
messages, even though there is.

Expected Results:  1. what *should* happen is the folder view updates w/out 
clicking inside it when new messages are found in this mailbox/folder on the 
IMAP server during/after a send/receive/synch process.

1. *ideally* functionality like that found in MS Outlook Express, etc would be 
available allowing fine grained control over the synch-process of IMAP 
folders.  eg, MS Outlook Express lets you select *how* the individual folders 
are kept in synch (eg only-headers/new-messages-only/all-messages/never) and 
updates whenever you synch or send/receive with the account.

Updated

16 years ago
Summary: folder summary not updated for new msgs → IMAP: folder summary not updated for new msgs

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 18266 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.