Closed Bug 1210513 Opened 4 years ago Closed 4 years ago

Direct calls don't cancel properly if you click the hangup button on the toolbar

Categories

(Hello (Loop) :: Client, defect, P2)

defect
Points:
1

Tracking

(firefox43+ fixed, firefox44+ fixed)

RESOLVED FIXED
mozilla44
Iteration:
44.1 - Oct 5
Tracking Status
firefox43 + fixed
firefox44 + fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file)

Regression from bug 1184921, STR:

1) Start a direct call
2) Click the hangup button on the toolbar

Expect Results

The call stops and the window is closed.

Actual Results

The call stops, but the window stays open (and is blank).
Rank: 25
Comment on attachment 8668594 [details] [diff] [review]
Loop's direct calls don't cancel properly if you click the hangup button on the toolbar.

Review of attachment 8668594 [details] [diff] [review]:
-----------------------------------------------------------------

Ooh, tricky states...
Attachment #8668594 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/mozilla-central/rev/616c04d4e5a1
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Flags: qe-verify+
QA Contact: bogdan.maris
Comment on attachment 8668594 [details] [diff] [review]
Loop's direct calls don't cancel properly if you click the hangup button on the toolbar.

Approval Request Comment
[Feature/regressing bug #]: Bug 1184921 (approval reqd for 43)
[User impact if declined]: Clicking the hangup button doesn't end a direct call properly so the user ends up with a blank window, and the peer may get notified incorrectly.
[Describe test coverage new/current, TreeHerder]: Landed in m-c with unit tests.
[Risks and why]: Low, handles a missing case.
[String/UUID change made/needed]: None
Attachment #8668594 - Flags: approval-mozilla-aurora?
Tracking since this is a regression.
Comment on attachment 8668594 [details] [diff] [review]
Loop's direct calls don't cancel properly if you click the hangup button on the toolbar.

Fixes recent regression, includes a new test. Approved for uplift to aurora.
Attachment #8668594 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Based on bug 1212083, direct calls are no longer possible so there is no point verifying this thus removing qe-verify+.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.