test_settings_usb_storage.py : TimeoutException: TimeoutException: Timed out after 10.3 seconds

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: MaxIvanov, Assigned: Martijn Wargers (dead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Description: Test case fails with "TimeoutException"

Steps:
1. Update a flame device to 20151002030232
2. Run this test case http://lxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_usb_storage.py

Actual result:
"TimeoutException"

Expected result:
Test completes successfully.

Repro Rate: Reproduced via Jenkins (0/5 passing)
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/267/HTML_Report/

 File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_usb_storage.py", line 20, in test_toggle_usb_storage
self.assertFalse(usb_storage.enabled)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/usb_storage.py", line 32, in enabled
return self._usb_checkbox.is_checked
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/usb_storage.py", line 36, in _usb_checkbox
return GaiaBinaryControl(self.marionette, self._usb_storage_checkbox_locator)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/form_controls/form_control.py", line 11, in __init__
element = Wait(marionette).until(expected.element_present(*locator))
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 10.3 seconds
(Reporter)

Comment 1

2 years ago
Created attachment 8668992 [details]
index.png
(Assignee)

Comment 2

2 years ago
This is due to the patch from bug 1203461.
Assignee: nobody → martijn.martijn
Blocks: 1203461

Comment 3

2 years ago
Created attachment 8669033 [details] [review]
[gaia] mwargers:1210834 > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8669033 - Flags: review?(npark)
Attachment #8669033 - Flags: review?(jdorlus)

Updated

2 years ago
Attachment #8669033 - Flags: review?(npark) → review+
Comment on attachment 8669033 [details] [review]
[gaia] mwargers:1210834 > mozilla-b2g:master

WFM and LGTM
Attachment #8669033 - Flags: review?(jdorlus) → review+
(Assignee)

Comment 5

2 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/9ccb896b4e4bddba39d8b4897deea69f5563ed51
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.