Closed Bug 1211016 Opened 6 years ago Closed 6 years ago

backout Bug 1194895 changes from beta release to avoid regression in Bug 1210091

Categories

(Firefox :: New Tab Page, defect, P1)

42 Branch
defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 42
Iteration:
44.2 - Oct 19
Tracking Status
firefox42 --- fixed

People

(Reporter: mzhilyaev, Assigned: mzhilyaev)

References

Details

Attachments

(1 file)

Following discussion in Bug 1210091, Bug 1194895 changes must be backed out from beta to avoid Bug 1210091 behavior
Approval Request Comment

This is a reverse patch of 1194895 patch.  However, I kept some of 1194895 changes to the newtab mochitests tests, as their removal causes cascading test failures.  

[Feature/regressing bug #]:
Bug 1211016 - backout Bug 1194895 changes from beta release to avoid regression in Bug 1210091

[User impact if declined]:

Very significant, as 1194895 changes caused 1211016 failure mode.
This is not a new bug - bug 1000097 was identified to have spotted identical issues, but it was dropped due to rare reproduction.  Fix to 1194895 caused conditions described in 1000097 appear far more often because the scrollbar on newtab allows bottom row of tiles to be partially visible. 
We need to remove newtab scrollbar in beta per dougt request.

[Describe test coverage new/current, TreeHerder]:

Since beta treeherder is noisy, I ran two try builds with and without the patch.
Try push with the patch:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=cf441ec4dffe

Try push without the patch:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=01cbd26274aa

I could not find significant differences, and the ones existing are not related to newtab.

I further tested manually on OsX, and verified that the scrollbar does not show up as expected.

[Risks and why]: 

Moderate risk - we are removing a significant UX function. However, the negative user impact outweighs the risks in this case.

[String/UUID change made/needed]:
None
Attachment #8669517 - Flags: approval-mozilla-beta?
Comment on attachment 8669517 [details] [diff] [review]
Bug-1211016.beta.v1.patch

OK, taking it for 42. Should be in beta 4.
What is the plan for 43 & 44?
Thanks
Flags: needinfo?(mzhilyaev)
Attachment #8669517 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
to the best if my knowledge the plan is to fix Bug 1210091 and have scrollbar on newtab in 43 and 44
Flags: needinfo?(mzhilyaev)
Taking in account Doug's comment in https://bugzilla.mozilla.org/show_bug.cgi?id=1210091#c1
I am considering this as an r+ from him and we can take it in 42.
Should be in beta 6
https://hg.mozilla.org/releases/mozilla-beta/rev/2743c9ab7748
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.