Closed Bug 1211138 Opened 9 years ago Closed 9 years ago

allow to use debug builds for inbound (TC)

Categories

(Testing :: mozregression, defect)

defect
Not set
normal

Tracking

(firefox44 affected)

RESOLVED FIXED
Tracking Status
firefox44 --- affected

People

(Reporter: parkouss, Assigned: parkouss)

References

Details

Attachments

(1 file)

Well James pinged me on irc and asked if we could use debug builds using mozregression.

Well no, not yet! But this would be a great feature to add, so I'm working on it.

Basically we can't do that for nightlies - only opt builds are kept - but inbound builds often have a debug build, so we can make this works for firefox and fennec inbounds. b2g-device will be handled later as it needs more discussion (but there will be debug also for those).

thunderbird is nightly only, and b2g desktop do not appear to have debug builds (at least from the task cluster routes I checked) - so it won't be available for those builds.

Thanks guys for raising this, a great feature to add! :)
Well I know that :wlach is like in PTO for one week, but I don't know who else can review it. If anyone wants to review that, feel free to do so!

I tested it and this seems to work well, using e.g:

> mozregression -g 2015-07-20 -b 2015-07-21 --build-type debug --log-mach-level debug

allows to download and run inbound debug builds (the process output is a lot more verbose than with opt builds). Also the filename used to keep the build is different from the opt build.
Assignee: nobody → j.parkouss
Status: NEW → ASSIGNED
Attachment #8669317 - Flags: review?(wlachance)
Blocks: 1211147
Blocks: 1211185
Please keep in mind that every mozilla-central Nightly build correspondes to a specific tinderbox build. So you may only have to find the appropriate tinderbox debug build for the given Nightly. Those builds are available on ftp/archive/s3. Here as example for linux64: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux64-debug/
(In reply to Henrik Skupin (:whimboo) from comment #2)
> Please keep in mind that every mozilla-central Nightly build correspondes to
> a specific tinderbox build. So you may only have to find the appropriate
> tinderbox debug build for the given Nightly. Those builds are available on
> ftp/archive/s3. Here as example for linux64:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-
> central-linux64-debug/

Thanks for the info Henrik!

Looking at the link it seems that there are not many builds - looks like we can't apply that for every nightlies - for example the one year old ones.

I think for mozregression we can just say that nightlies do not have debug builds, but we should add m-c builds available using inbounds (and so allow debug builds for recent m-c builds).

Said like this that has probably not much sense - but I am thinking that we should consider for mozregression "short term builds" (using taskcluster, and whatever branch) against "long term builds" (using a.m.o ftp) - instead of our current "nightlies" against "inbounds". And in that case short term builds using m-c would have debug option available.

But this is out of this bug concern - The point is that for now I would stick with "no debug for nightlies" (unless I am misunderstanding something here, please correct me then!).
inbound-archive will give us more builds (as of today dating back to March 15th 2015):
http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux64-debug/

I would assume for most cases it would be enough. IMO we could check if a debug build is available, if not just fallback to a non-debug version.
Well, that worth the investigation, but this would require more changes and thinking.

So let's focus on the inbound (TaskCluster) part for now.
Summary: allow to use debug builds → allow to use debug builds for inbound (TC)
Comment on attachment 8669317 [details] [review]
allow to use debug builds

LGTM. One very minor nit mentioned in PR. Thanks!
Attachment #8669317 - Flags: review?(wlachance) → review+
Thanks Will, fixed and merged in https://github.com/mozilla/mozregression/commit/a265d5fcf19b7d02b9b692307fcd5d7c0046163e.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Thanks for doing this! Having to build locally to test debug-only issues is a royal pain :)
You need to log in before you can comment on or make changes to this bug.