Closed Bug 1211226 Opened 6 years ago Closed 6 years ago

Site icon resolution on Android home screen is lower than expected

Categories

(Firefox for Android Graveyard :: Favicon Handling, defect)

41 Branch
defect
Not set
normal

Tracking

(fennec45+)

RESOLVED DUPLICATE of bug 826400
Tracking Status
fennec 45+ ---

People

(Reporter: i, Unassigned)

References

Details

Attachments

(1 file)

Attached image 2015-10-04 10.56.46.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 2015091800

Steps to reproduce:

I have my blog http://guoyunhe.me/zh/ and set multiple favicon sizes:

        <link rel="icon" href="/img/icon/16.png" sizes="16x16" />
        <link rel="icon" href="/img/icon/32.png" sizes="32x32" />
        <link rel="icon" href="/img/icon/64.png" sizes="64x64" />
        <link rel="icon" href="/img/icon/128.png" sizes="128x128" />
        <link rel="icon" href="/img/icon/256.png" sizes="256x256" />
        <link rel="icon" href="/img/icon/1024.png" sizes="1024x1024" />

I add my blog to Android home screen through Firefox, like an application icon.

My device is LG Nexus 5, 1920x1080px 4.9 inch screen. Firefox for Android 41.0


Actual results:

The icon in Android home screen show a low resolution image. I guess it is using 64x64px image.


Expected results:

But it should use 256x256px or higher. Attached file shows icon created by Firefox for Android (left) and Chrome for Android (right).
tracking-fennec: --- → ?
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826400
(Closed – dupe)
tracking-fennec: ? → ---
Status: RESOLVED → REOPENED
tracking-fennec: --- → 45+
Ever confirmed: true
Resolution: DUPLICATE → ---
Blocks: progressive-apps
No longer blocks: fennec-polish
Oops, looks like I accidentally re-opened this.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826400
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.