Sound indicator is displayed on vk.com while nothing is causing sound

VERIFIED FIXED in Firefox 44

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: arni2033, Assigned: baku)

Tracking

Trunk
Firefox 44
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 verified)

Details

()

Attachments

(1 attachment)

STR:   (Win7_64, Nightly 43, 32bit, ID 20150910030225, new profile, safe mode)
0. Open   about:addons (Ctrl+Shift+A), disable Flash Plugin ("Never Activate")
1. Open   https://vk.com/video211054116_167519691
2. Click video to play it   [make sure the video starts playing and sound indicator is displayed]
3. Click outside of the video

Result:       Video is closed, <video> element is deleted, but the sound indicator is still displayed
Expectations: Shound indicator should disappear, just like in Chrome

I *checked*: it always happen when I remove [src] of any <video> and then remove <video> element
Andrea, maybe this is an edge case that got missed ?
Flags: needinfo?(amarchesini)
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Posted patch notify.patchSplinter Review
The bug here is that NotifyStartedPlaying and NotifyStoppedPlaying are inconsistent about the notification of playback. This happens because HasAudio() returns true and then false.
With this patch NotifyStoppedPlaying follows the notification playback flag of NotifyStartedPlaying.
Attachment #8670373 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/1418f98468c3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Verified fixed on latest Nightly 44.0a1 (buildID: 20151011030229).
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1225051
You need to log in before you can comment on or make changes to this bug.