RSS feed select dropdown list background is transparent

VERIFIED FIXED in Firefox 43

Status

()

Firefox
RSS Discovery and Preview
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Alice0775 White, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

43 Branch
Firefox 45
Unspecified
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox42 unaffected, firefox43+ fixed, firefox44+ verified, firefox45 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8669993 [details]
screenshot

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/b56aeea0c4701677ffda6417183caa60d2a6a4a7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0 ID:20151005030206
https://hg.mozilla.org/releases/mozilla-aurora/rev/58f5e8ddaa59b31dec9938a83cc24210cb514896
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20151005004046


Steps To Reproduce:
0. Disable e10s and restart
1. Open web page with RSS deed (E.x. https://wiki.mozilla.org/WebExtensions )
2. "Bookmarks – Subscribe to This Page…"
3. Click Select dropdown marker

Actual Results:
The dropdown list background is transparent
(Reporter)

Updated

2 years ago
Keywords: regression
Version: 44 Branch → 43 Branch
Probably some package needs to be marked as loadable from content.
(In reply to Jonas Sicking (:sicking) from comment #2)
> Probably some package needs to be marked as loadable from content.

Jonas already gave a very detailed explanation over in Bug 1205052 which is worth cross posting here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1205052#c23
Flags: needinfo?(mozilla)

Comment 4

2 years ago
Tracking in 44 Nightly because this is is a regression, is visible to users and could have potential impact.
tracking-firefox44: ? → +
Does the error console contain any information? What if you reload the page?
(Reporter)

Comment 7

2 years ago
(In reply to Jonas Sicking (:sicking) from comment #6)
> Does the error console contain any information?

No error in Browser Console.

> What if you reload the page?

Nothing is changed. The problem persists.
(Assignee)

Comment 8

2 years ago
(In reply to Christoph Kerschbaumer from comment #3)
> (In reply to Jonas Sicking from comment #2)
> > Probably some package needs to be marked as loadable from content.
(Assignee)

Comment 9

2 years ago
Sorry, misclick.

(In reply to Jonas Sicking from comment #2)
> Probably some package needs to be marked as loadable from content.

There are no custom styles applied to the menupopup, its computed binding is chrome://global/content/bindings/popup.xml#popup-scrollbars which is already loadable from content (line 2 of toolkit.jar).

Is there somewhere I can breakpoint to find out why the load failed?
Hrm.. if this is already a web-exposed package then I'm not really sure what's going on. A good place to start would likely be to step through any calls to nsContentSecurityManager::doContentSecurityCheck.
We should be tracking this in 43 as well since the regression began there. 

Looks like there is also discussion over in https://bugzilla.mozilla.org/show_bug.cgi?id=1195162#c64. 

Christoph or Jonas, this looks like a side effect of work that you all are doing; is this something you can also take on? Do you think it will be addressed by what you're already working on?  While it's a regression, it seems fairly minor in itself. So we might end up wontfixing this for 43.
tracking-firefox43: ? → +
Flags: needinfo?(mozilla)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #11)
> We should be tracking this in 43 as well since the regression began there. 
> 
> Looks like there is also discussion over in
> https://bugzilla.mozilla.org/show_bug.cgi?id=1195162#c64. 
> 
> Christoph or Jonas, this looks like a side effect of work that you all are
> doing; is this something you can also take on? Do you think it will be
> addressed by what you're already working on?  While it's a regression, it
> seems fairly minor in itself. So we might end up wontfixing this for 43.

Thanks Liz for keeping track of things. I will have a look later this week. Leaving ni? flag for now so it gets my attention.
(Assignee)

Comment 13

2 years ago
(In reply to Jonas Sicking from comment #10)
> Hrm.. if this is already a web-exposed package then I'm not really sure
> what's going on. A good place to start would likely be to step through any
> calls to nsContentSecurityManager::doContentSecurityCheck.

I tried that but it just returns NS_OK in the case of popup.xml.
(Assignee)

Comment 14

2 years ago
The binding for the dropdown list happens to be set in the theme, rather than content. Bug 1195162 accidentally removed the ability for themes to set bindings in insecure documents.
(Assignee)

Comment 15

2 years ago
Created attachment 8683178 [details] [diff] [review]
Possible patch

This fixes it for me. I believe that this just allows the theme to specify the binding; the binding itself still needs to be accessible to content in the normal way.
Attachment #8683178 - Flags: review?(mozilla)
Comment on attachment 8683178 [details] [diff] [review]
Possible patch

Review of attachment 8683178 [details] [diff] [review]:
-----------------------------------------------------------------

Please add a comment indicating why this is needed.
Attachment #8683178 - Flags: review?(mozilla) → review+
(In reply to Jonas Sicking (:sicking) from comment #16)
> Please add a comment indicating why this is needed.

Thanks Jonas for jumping in. Looks good - thanks for fixing.
Flags: needinfo?(mozilla)

Comment 19

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/21a2e66bf784
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
(Assignee)

Comment 20

2 years ago
Comment on attachment 8683178 [details] [diff] [review]
Possible patch

Approval Request Comment
[Feature/regressing bug #]: 1195162
[User impact if declined]: Mostly display issue
[Describe test coverage new/current, TreeHerder]: Don't ask don't tell
[Risks and why]: Low, surgical backout
[String/UUID change made/needed]: None
Attachment #8683178 - Flags: approval-mozilla-beta?
Attachment #8683178 - Flags: approval-mozilla-aurora?
Assignee: nobody → neil
Comment on attachment 8683178 [details] [diff] [review]
Possible patch

Ugly visual regression, taking it.
Should be in 43 beta 2.
Attachment #8683178 - Flags: approval-mozilla-beta?
Attachment #8683178 - Flags: approval-mozilla-beta+
Attachment #8683178 - Flags: approval-mozilla-aurora?
Attachment #8683178 - Flags: approval-mozilla-aurora+

Comment 22

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/f250ff2ead10
status-firefox44: affected → fixed

Comment 23

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/1a56a93a6292
status-firefox43: affected → fixed
Flags: qe-verify+

Comment 25

2 years ago
Reproduced with Nightly from 2015-10-03.
Verified fixed with latest 44.0a2 (from 2015-11-10) and 45.0a1 (from 2015-11-09), across platforms [1].

[1] Windows 7 64-bit, Mac OS X 10.11.1 and Ubuntu 14.04 32-bit
Status: RESOLVED → VERIFIED
status-b2g-v2.5: fixed → ---
status-firefox44: fixed → verified
status-firefox45: fixed → verified
Flags: qe-verify+

Updated

2 years ago
Duplicate of this bug: 1214977
You need to log in before you can comment on or make changes to this bug.