The default bug view has changed. See this FAQ.

walking through thread pane with preview collapsed should set title to folder name

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
trivial
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: timeless, Assigned: neil@parkwaycc.co.uk)

Tracking

(Depends on: 1 bug, 5 keywords)

Trunk
fixed-seamonkey1.0.2, fixed-seamonkey1.1a, fixed1.8.0.4, fixed1.8.1, polish
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
mozilla currently wastes my eye cycles changing the window title to match the 
message while the preview is collapsed. this is annoying and makes it hard for 
me to find the folder i was browsing by checking the taskbar.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
QA Contact: esther → olgam

Comment 1

15 years ago
I agree. 

http://www.mozilla.org/mailnews/specs/threepane/#Title

"If a particular message has not yet been selected, or the "Message" pane is 
closed, the <Subject> would be omitted from the examples above where 
appropriate."
(Assignee)

Comment 2

15 years ago
Created attachment 95107 [details] [diff] [review]
Proposed patch
(Assignee)

Updated

15 years ago
Severity: enhancement → trivial
Keywords: patch, polish, review, ui
(Assignee)

Comment 3

15 years ago
Patch collision - Bug 127409's patch got mixed in, sorry :-)
(Reporter)

Updated

15 years ago
Attachment #95107 - Flags: review+
(Assignee)

Comment 4

15 years ago
Created attachment 95572 [details] [diff] [review]
Fixed setting the title when uncollapsing

Fortunately gDBView.reloadMessage will do nothing when I'm collapsing the pane.

However it's the only way I could figure out to set the title.
I really need to call nsMsgDBView::UpdateDisplayMessage but that's only called
either from LoadMsgByMsgKeyHelper which is called by ReloadMessage, or from
ndMsgDBView::SelectionChanged, but I can't get that case to work :-(
Attachment #95107 - Attachment is obsolete: true
(Reporter)

Updated

15 years ago
Attachment #95572 - Flags: superreview?(sspitzer)
Attachment #95572 - Flags: review?(sspitzer)
(Reporter)

Updated

13 years ago
Assignee: sspitzer → neil.parkwaycc.co.uk
Product: Browser → Seamonkey
(Reporter)

Updated

12 years ago
Attachment #95572 - Flags: superreview?(sspitzer)
Attachment #95572 - Flags: superreview?(dmose)
Attachment #95572 - Flags: review?(sspitzer)
Attachment #95572 - Flags: review?(dmose)

Comment 5

12 years ago
Comment on attachment 95572 [details] [diff] [review]
Fixed setting the title when uncollapsing

r+sr=dmose
Attachment #95572 - Flags: superreview?(dmose)
Attachment #95572 - Flags: superreview+
Attachment #95572 - Flags: review?(dmose)
Attachment #95572 - Flags: review+
(Assignee)

Comment 6

12 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

12 years ago
Created attachment 200995 [details] [diff] [review]
Fix grippy clicking

I was having issues with grippy clicking because I was seeing too many events.
I also switched back to selectionChanged as it seems to be more reliable.
Attachment #200995 - Flags: review?(mnyromyr)
Depends on: 314301
Keywords: 4xp
Summary: [4xp] walking through thread pane with preview collapsed should set title to folder name → walking through thread pane with preview collapsed should set title to folder name

Comment 8

12 years ago
Comment on attachment 200995 [details] [diff] [review]
Fix grippy clicking

Can you elaborate a bit on what exactly this patch is about to fix? What "issues" did you run into?

Comment 9

12 years ago
Comment on attachment 200995 [details] [diff] [review]
Fix grippy clicking

Okay, so ChangeMessagePaneVisibility is now only called once when toggling the message pane, and the error seen in 314301 is gone, too. :)
Attachment #200995 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 10

12 years ago
Comment on attachment 200995 [details] [diff] [review]
Fix grippy clicking

Note: I'm not convinced many people do this, so it won't have got much testing
Attachment #200995 - Flags: approval-seamonkey1.0?

Comment 11

12 years ago
Comment on attachment 200995 [details] [diff] [review]
Fix grippy clicking

a=me given none of the touched files is shared with Thunderbird...
Attachment #200995 - Flags: approval-seamonkey1.0? → approval-seamonkey1.0+

Comment 12

11 years ago
Comment on attachment 200995 [details] [diff] [review]
Fix grippy clicking

Re-requesting approval for branches as this never got checked into the branch.
Attachment #200995 - Flags: approval-seamonkey1.1a?
Attachment #200995 - Flags: approval-seamonkey1.0.2?

Comment 13

11 years ago
Comment on attachment 200995 [details] [diff] [review]
Fix grippy clicking

Given there are no other objections since I did that last time, a=me again for 1.8-based code :)
Attachment #200995 - Flags: approval-seamonkey1.1a?
Attachment #200995 - Flags: approval-seamonkey1.1a+
Attachment #200995 - Flags: approval-seamonkey1.0.2?
Attachment #200995 - Flags: approval-seamonkey1.0.2+

Comment 14

11 years ago
Created attachment 217700 [details] [diff] [review]
Combined patch for branches (Checked in 1.8 & 1.8.0 branches)

This is the equivalent combined patch for either of the branches.

Comment 15

11 years ago
Comment on attachment 217700 [details] [diff] [review]
Combined patch for branches (Checked in 1.8 & 1.8.0 branches)

Checking in (1.8 branch)
commandglue.js;
new revision: 1.258.4.6; previous revision: 1.258.4.5
mail3PaneWindowVertLayout.xul;
new revision: 1.106.2.4; previous revision: 1.106.2.3
messenger.xul;
new revision: 1.258.2.4; previous revision: 1.258.2.3
threadPane.js;
new revision: 1.80.4.5; previous revision: 1.80.4.4
widgetglue.js;
new revision: 1.171.4.1; previous revision: 1.171
done

Checking in (1.8.0 branch)
commandglue.js;
new revision: 1.258.10.6; previous revision: 1.258.10.5
mail3PaneWindowVertLayout.xul;
new revision: 1.106.2.1.2.3; previous revision: 1.106.2.1.2.2
messenger.xul;
new revision: 1.258.2.1.2.3; previous revision: 1.258.2.1.2.2
threadPane.js;
new revision: 1.80.12.2; previous revision: 1.80.12.1
widgetglue.js;
new revision: 1.171.12.1; previous revision: 1.171
done
Attachment #217700 - Attachment description: Combined patch for branches → Combined patch for branches (Checked in 1.8 & 1.8.0 branches)

Updated

11 years ago
Keywords: fixed-seamonkey1.1a, fixed1.8.0.3, fixed1.8.1
Whiteboard: fixed-seamonkey1.0.2

Updated

11 years ago
Keywords: fixed-seamonkey1.0.2
Whiteboard: fixed-seamonkey1.0.2
Depends on: 315957
You need to log in before you can comment on or make changes to this bug.