[Browser] In new homescreen, tap browser icon would bring up new browser windows when some unpin pages already opened

RESOLVED DUPLICATE of bug 1213883

Status

Firefox OS
Gaia::Browser
P2
normal
RESOLVED DUPLICATE of bug 1213883
3 years ago
3 years ago

People

(Reporter: Alison Shiue, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe], URL)

(Reporter)

Description

3 years ago
STR:
1. Switch to the new homescreen
2. Open some unpin pages 
3. Go back to homescreen, and tap browser icon

Expected result:
1. Would just bring up the most latest opened unpin page no matter it is private or normal window

Actual result:
1. Open a new browser window

Build info:
[Flame]
Build ID               20151005150202
Gaia Revision          1f226126dcba8af16c8db08556130b0bb04bb8d3
Gaia Date              2015-10-05 15:11:34
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/67adec79eb8a481d87721a10b2aa733020d326eb
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151005.182526
Firmware Date          Mon Oct  5 18:25:38 EDT 2015
Bootloader             L1TC000118D0

[Aries]
Build ID               20151005211038
Gaia Revision          1f226126dcba8af16c8db08556130b0bb04bb8d3
Gaia Date              2015-10-05 15:11:34
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/67adec79eb8a481d87721a10b2aa733020d326eb
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151005.203012
Firmware Date          Mon Oct  5 20:30:20 UTC 2015
Bootloader
(Reporter)

Comment 1

3 years ago
[Blocking Requested - why for this release]:
Inconsistent behavior with the browser in old homescreen
blocking-b2g: --- → 2.5?
QA Whiteboard: [COM=Pin the Web]
Not blocking the release for it since it doesn't hamper usability. But setting high priority.
Blocks: 1168939
blocking-b2g: 2.5? → ---
Priority: -- → P2
Whiteboard: [systemsfe]
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213883
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=Pin the Web]
You need to log in before you can comment on or make changes to this bug.