Unable to connect to a secure WiFi network in Settings, unselectable 'OK' button.

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][dogfood-blocker], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Description:
After the user has selected a password protected WiFi network, they are able to input the password, but the 'OK' button does not become selectable after typing 8 characters in the password field, preventing the user from connecting to the network.

Note: The user IS able to connect to a WiFi network in the FTU.

Repro Steps:
1) Update a Aries to 20151006110922
2) Open the Settings app
3) Navigate to WiFi, and select a network
4) Input the password


Actual:
The 'OK' button does not activate, preventing the user from connecting to the network.

Expected:
The 'OK' button activate, and is functional, after inputting at least 8 characters in the password field.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151006110922
Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
Gecko: 89732fcdb0baca70e8b7a25a2725117113f0db80
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/6075/
See attached: Screenshot, Logcat
(Reporter)

Comment 1

2 years ago
This issue DOES occur on the latest 2.5 Flame build.
The 'OK' button does not activate, preventing the user from connecting to the network.

Environmental Variables:
Device: Flame 2.5
BuildID: 20151006030203
Gaia: 60cdaa3d3424db3432dc903e7f9c6c8fa099c06d
Gecko: 3edc8d4a1e198314f5d7ebd2967b85842beef602
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

-------------------------------------------------------------------------------------------

This issue does NOT occur on yesterday's Aries build, or on the latest Flame 2.2 build.
The 'OK' button activate, and is functional, after inputting at least 8 characters in the password field.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151005111147
Gaia: b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9
Gecko: 45f01961ecd0ad9a45067f3e08bfb92539042eeb
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

2 years ago
Created attachment 8670363 [details]
logcat_WiFi.txt
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(ktucker)
Keywords: qaurgent, regressionwindow-wanted
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][dogfood-blocker]
(Reporter)

Updated

2 years ago
QA Contact: pcheng
blocking-b2g: 2.5? → 2.5+
Priority: -- → P1
b2g-inbound regression window:

Last Working
Device: Flame 2.5
BuildID: 20151004221436
Gaia: b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9
Gecko: a097454ca61bff12f877001f7f116d924112fd2a
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Device: Flame 2.5
BuildID: 20151005001708
Gaia: a13057e1fbdc7e2b0f0f2469d6f22676239ba24d
Gecko: 0d52d0d26e28d40db3c54acca7629f4454c58518
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working Gaia First Broken Gecko - no repro
Gaia: b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9
Gecko: 0d52d0d26e28d40db3c54acca7629f4454c58518

Last Working Gecko First Broken Gaia - repro
Gaia: a13057e1fbdc7e2b0f0f2469d6f22676239ba24d
Gecko: a097454ca61bff12f877001f7f116d924112fd2a

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/b994cedaa7ef9bfadcbe841601d9dc8d2e5379f9...a13057e1fbdc7e2b0f0f2469d6f22676239ba24d

Caused by changes made in Bug 1170236.
Blocks: 1170236
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qaurgent, regressionwindow-wanted
Evan, this issue seems to have been caused by the changes for bug 1170236.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(evan)
Workaround for anyone affected: open settings app in WebIDE and paste the following in console to re-enable the button:

document.querySelector('#wifi-auth > gaia-header:nth-child(1) > button:nth-child(3)').disabled=false
Bug 1170236 is backed out.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Duplicate of this bug: 1212221

Comment 9

2 years ago
Found out the root cause[1].

[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=1170236#c28
Flags: needinfo?(evan)
(Reporter)

Comment 10

2 years ago
This issue is verified fixed on the latest Aries and Flame 2.5 master builds.
The 'OK' button activate, and is functional, after inputting at least 8 characters in the password field.

Environmental Variables:
Device: Aries 2.5
BuildID: 20151008143352
Gaia: 4973f57cd8f9a62a95f783a24eac32da2bde99fc
Gecko: 1f4cf75c894862cf3634d6014d8de9c807a054a7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20151008062742
Gaia: 4973f57cd8f9a62a95f783a24eac32da2bde99fc
Gecko: 1f4cf75c894862cf3634d6014d8de9c807a054a7
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.