Closed Bug 1212080 Opened 6 years ago Closed 6 years ago

[e10s] Alt+Shift+S does Alt+S now

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

39 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1101975
Tracking Status
e10s ? ---

People

(Reporter: gladjonatan, Unassigned)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151004030211

Steps to reproduce:

Pressing Alt+Shift+S used to not do anything in Firefox, allowing Wikimedia wikis to use tat as a keyboard shortcut to save edits.


Actual results:

Now it does the same thing as Alt+S, which is redundant.


Expected results:

Nothing natively.

----
Downstream bug @ Wikimedia bug tracker Phabriator: https://phabricator.wikimedia.org/T114793
Keywords: regression
Component: Untriaged → Keyboard: Navigation
Product: Firefox → Core
I tested this demo:
http://demo.opensourcecms.com/mediawiki/index.php/Main_Page

With FF44, Alt+Shift+S save the article.
Alt+S opens the History entry in the menu bar.
(In reply to Loic from comment #1)
> I tested this demo:
> http://demo.opensourcecms.com/mediawiki/index.php/Main_Page
> 
> With FF44, Alt+Shift+S save the article.
> Alt+S opens the History entry in the menu bar.

Odd. Can you try on https://en.wikipedia.org/wiki/User:Josve05a/sandbox/Firefox to see if this is Wiki[p|m]edia-specific, or perhaps just me.
Flags: needinfo?(epinal99-bugzilla2)
Same result.
Flags: needinfo?(epinal99-bugzilla2)
I tried that, I'm still getting the same result.
Can you check the pref "ui.key.contentAccess" in your about:config, it should be 5 (Alt+Shift).
Flags: needinfo?(gladjonatan)
Keywords: regressionsteps-wanted
Summary: Remove the keyboard shortcut Alt+Shift+S which was recently added → Alt+Shift+S does Alt+S now in Fx44
(In reply to YF (Yang) from comment #6)
> Can you check the pref "ui.key.contentAccess" in your about:config, it
> should be 5 (Alt+Shift).

ui.key.contentAccess;5
Flags: needinfo?(gladjonatan)
Flags: needinfo?(felipc)
This issue seems e10s specific. It works fine in Firefox release version but fails in nightly and aurora(e10s enabled channels). When e10s is disabled, it does not reproduce. 

Affected versions/channels:
-aurora 
-nightly

Affected platforms:
- Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
- Mozilla/5.0 (Windows NT 6.3; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Steps to reproduce:
1.Edit the following Wikipedia demo page using e10s enabled Firefox browser.
Demo page: https://en.wikipedia.org/w/index.php?title=User:LVTesting&action=edit

2.Press Alt+Shift+S to save the page.

Expected result:
Page should be saved using Alt+Shift+S. 

Actual result:
Alt+Shift+S works the same as Alt+S when e10s is enabled. 
If e10s is disabled, page can be saved using Alt+Shift+S.

Aurora Regression Range:
 Last good revision: a019592053c4d93fbbafab8d0bd709529e3746de
 First bad revision: 7308dd0a6c3b7049dbd8346c7f435c5e03500b65
 Pushlog: https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=a019592053c4d93fbbafab8d0bd709529e3746de&tochange=7308dd0a6c3b7049dbd8346c7f435c5e03500b65
Status: UNCONFIRMED → NEW
tracking-e10s: --- → ?
Ever confirmed: true
Keywords: steps-wanted
(In reply to YF (Yang) from comment #9)
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=33b68aec2ab9560023be4a003b71b7a4a023fb9e&tochange=30bf
> 6cb70f615d9ffb9a0e55220f8c15075b700e

I don't understand the result because bug 1147722 was already reverted since most TSF related bugs had been fixed. See bug 1187579.
Flags: needinfo?(yfdyh000)
(In reply to Masayuki Nakano [:masayuki] (Mozilla Japan) from comment #10)
> (In reply to YF (Yang) from comment #9)
> > https://hg.mozilla.org/integration/mozilla-inbound/
> > pushloghtml?fromchange=33b68aec2ab9560023be4a003b71b7a4a023fb9e&tochange=30bf
> > 6cb70f615d9ffb9a0e55220f8c15075b700e
> 
> I don't understand the result because bug 1147722 was already reverted since
> most TSF related bugs had been fixed. See bug 1187579.

Maybe the "Remove keyboardMayHaveIME method." causing the issue.


I see the hotkey works if I placed the focus in chrome ui (like urlbar / search bar), the hotkey work but Alt+key is triggered too. Nightly 48.0a1 (2016-03-13) e10s on.
Flags: needinfo?(yfdyh000)
(In reply to YF (Yang) from comment #11)
> I see the hotkey works if I placed the focus in chrome ui (like urlbar /
> search bar), the hotkey work but Alt+key is triggered too. Nightly 48.0a1
> (2016-03-13) e10s on.

Since https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=37c7812ce0e6d10c7e7182f12e752832835e1d67&tochange=eb30e5ee32f0a11e3df594b5b3e69d0a5566bb63. Likely to bug 1168042.
See Also: → 1168042
Summary: Alt+Shift+S does Alt+S now in Fx44 → [e10s] Alt+Shift+S does Alt+S now
Blocks: e10s
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1101975
Flags: needinfo?(felipc)
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.