[e10s] Process-per-tab Firefox uses more private bytes than Chrome or IE

RESOLVED WORKSFORME

Status

()

Core
DOM: Content Processes
RESOLVED WORKSFORME
2 years ago
9 days ago

People

(Reporter: vladan, Unassigned)

Tracking

(Blocks: 2 bugs)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [MemShrink:P1])

(Reporter)

Description

2 years ago
Compared to Chrome, Firefox memory usage does not scale well in its process-per-tab configuration. It is also worse than IE, but comparable to the current Edge. Chrome, IE and Edge are already process-per-tab browsers (up to a limit).

The different browsers’ memory usage was compared using Windows’ Task Manager, specifically “Memory (Private Bytes)” measurement.

Differences emerged with as few as 4 tabs. We’ll need to optimize the content processes’ memory usage before we can ship with multiple content processes.

Findings in table form:
https://docs.google.com/spreadsheets/d/1yxPlTluNeNjZTdq7bGDJL8iyEaGkCHksBrEEaZxd7Ao/edit#gid=0

Details of measurements (newsgroup thread): 
https://mail.mozilla.org/pipermail/contentperf/2015-September/thread.html#14
Whiteboard: [MemShrink]
(Reporter)

Updated

2 years ago
Blocks: 1213469
Not that I know exactly what Private Bytes measures, but it looks like it's truly private space and therefore doesn't count any shared memory, included memory that is only shared between content processes. Which may be fine, but it strikes me that you can "win" on this metric by using shared memory pools across all of the content processes, which might even make sense as a low-overhead way of communicating. Are there measurements to show that this is not happening in eg Chrome?

In something like firefox e10s-8, do you have any details on where the memory is going, eg from about:memory dumps? It might help in moving this bug towards something actionable.
Flags: needinfo?(vladan.bugzilla)
(Reporter)

Comment 2

2 years ago
We haven't analyzed the memory usage beyond measuring it in aggregate. This bug (and the other blockers of bug 1213469) are reports of "symptoms", we'll follow up with analyses and file additional bugs in the future.
Note that there does not seem to be much of a rush to optimize e10s process memory usage right now, in large part because process-per-tab is not going to be initial e10s configuration shipped and because some amount of e10s memory usage impact is expected.
Flags: needinfo?(vladan.bugzilla)

Updated

2 years ago
Blocks: 1063169
tracking-e10s: --- → +
Getting a better idea of how much memory overhead there is for e10s is a Q4 goal for me, I'm happy to coordinate efforts here.
Whiteboard: [MemShrink] → [MemShrink:P1]
Blocks: 1207306
No longer blocks: 1063169
Summary: [e10s] Process-per-tab Firefox uses more memory than Chrome or IE → [e10s] Process-per-tab Firefox uses more private bytes than Chrome or IE

Updated

7 months ago
Duplicate of this bug: 1313851
I don't think there's anything actionable here at this point. We've done plenty of measurement for e10s-multi and found a reasonable number of content processes to use.
Status: NEW → RESOLVED
Last Resolved: 9 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.