Closed Bug 1213591 Opened 6 years ago Closed 3 years ago

(B2G 2.5) Impossible to activate bluetooth

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: u547545, Unassigned)

Details

(Whiteboard: [mozfr-community])

Attachments

(11 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150929144111

Steps to reproduce:

1) Go to "Settings",
2) In the "Network & Connectivity", click on "Bluetooth",
3) Enable Bluetooth.
-> The button changes from gray to blue: Bluetooth should be activated.



Actual results:

Bluetooth is however not activated.
(The blue button changes to gray after leaving the page).


Expected results:

Bluetooth should be activated and remain activated.

-----------
Tested with ZTE Open C (FR)
OS Version: 2.5.0.0-prerelease
Build Number: eng..20140806.064432
Platform Version: 44.0a1
Build Identifier: 201510010002247
Update Channel: nightly
Git Commit Info: 2015-10-09 21:39:30 (7f532564)
Hi
How do you upgrade OpenC to gecko v2.5?
Can you check you have /system/bin/bluetoothd in your phone?
You need to have /system/bin/bluetoothd and /system/lib/libfdio.so.
Flags: needinfo?(biio)
Hi !
I installed version 2.5 by following this tutorial: http://builds.firefoxos.mozfr.org/doc/fr/devices/zte-open-c-fr .

I have /system/bin/bluetoothd in my phone, but I HAVE NOT /system/lib/libfdio.so .


Do you need more informations?
Flags: needinfo?(biio)
Attached video VID_0262.3gp
I don't have OpenC device currently. Can you provide logcat log (recording when you turn bluetooth on at the first time)?
To get adb logcat, you can type:
$adb logcat -v > logcat.txt

And upload logcat.txt to the bug.
Sorry, I'm not sure now OpenC is based on Android ICS or Android JB if you use update.zip to update.
And how update.zip been created.

If your OpenC build is Android ICS based, the bluetooth backend is based on BlueZ. If it's after Android JellyBean MR2, that should be bluedroid based. Gecko v2.5 already switched to bluedroid and uses bluetooth daemon to communicate with bluedroid backend for device builds are based on later than Android JellyBean.
Flags: needinfo?(biio)
I didn't know what "logcat" you provide, so, I sent everything.

You have what you need?
Hello,

I'm in the same situation as Stephane (except for gecko/gaia version, more recent for me).
If it can help, I got these informations with getprop from my Open C FR :
---
[ro.build.description]: [msm8610-eng 4.3 JLS36C eng..20140806.064432 test-keys]
[ro.build.display.id]: [FFOS_FR_ZTE_OPENCV1.0.0B02]
[ro.build.fingerprint]: [ZTE/ZTE_OPENC/ZTE_P821A10:4.3/JLS36C/eng..20140806.064432:eng/test-keys]
[ro.build.host]: [SCL-6SH147]
[ro.build.id]: [JLS36C]
[ro.build.inner.version]: [FFOS_FR_ZTE_P821A10V1.0.0B02]
[ro.build.product]: [ZTE_P821A10]
(...)
[ro.qc.bluetooth.stack]: [bluez]
---
So, it is Jelly Bean based.

The updates builded by community, upgrade only gecko and gaia parts on the Open C.

For the logcat, I didn't see any specific line, when I tried to turn on bluetooth.
Hello,

Shawn, do you need additional informations ?
How can I help to get this bug resolved ?
is there any config to build OpenC for v2.5?
Flags: needinfo?(shuang)
Hi,

I can't find the source to install version 2.5 of the Open C.
However, here is the link to install version 2.6, currently on the Nightly channel: http://builds.firefoxos.mozfr.org/openc/nightly/.
On version 2.6 we find the same Bluetooth problem on version 2.5.
(In reply to Stephane Stenger from comment #10)
> Hi,
> 
> I can't find the source to install version 2.5 of the Open C.
> However, here is the link to install version 2.6, currently on the Nightly
> channel: http://builds.firefoxos.mozfr.org/openc/nightly/.
> On version 2.6 we find the same Bluetooth problem on version 2.5.

I guess there is no active development for ICS based BlueZ backend for a while (since v1.4).
We all move to bluedroid backend.
But i will try to setup one device for debugging.
hi,
this bug occurs since half of September at last.
we see nothing in logcat (also with output of bluetooth in log settings active) but i'll attach one.

for build we use manifest attach in bug #1016867
Attached file openc_2.5.xml
Here is the manifest, modified for building 2.5 versions of Gecko and Gaia.
(In reply to micgeri from comment #13)
> Created attachment 8689561 [details]
> openc_2.5.xml
> 
> Here is the manifest, modified for building 2.5 versions of Gecko and Gaia.
This is really helpful! I will build and take a look. 
Thanks!
(In reply to Shawn Huang [:shawnjohnjr] from comment #11)
> (In reply to Stephane Stenger from comment #10)
> > Hi,
> > 
> > I can't find the source to install version 2.5 of the Open C.
> > However, here is the link to install version 2.6, currently on the Nightly
> > channel: http://builds.firefoxos.mozfr.org/openc/nightly/.
> > On version 2.6 we find the same Bluetooth problem on version 2.5.
> 
> I guess there is no active development for ICS based BlueZ backend for a
> while (since v1.4).
> We all move to bluedroid backend.
> But i will try to setup one device for debugging.

I was wrong. After checking my OPENC version, it looks like JB instead of ICS.

[ro.build.inner.version]: [FFOS_EU_EBAY_P821A10V1.0.0B06]
[ro.build.version.release]: [4.3]
[ro.build.version.sdk]: [18]
Gaia can't get default adapter from GeckoBluetooth due to Bluetooth API v2 doesn't support BlueZ backend. I will try to analyze how much effort to bring bluetooth feature back.
I think OpenC still uses BlueZ4 on Android 4.3 just because the historic reason. v1.4 to v2.0, bluedroid support is not good enough for release.
Since original Android 4.3 JellyBean already ship with bluedroid, i think we shall switch bluetooth stack to bluedroid.

This will be easier for team.
After updating my repo with the modified xml file, and applying the patch, the build of bluetoothd and the full ./build.sh failed with this error :
>Export includes file: system/libfdio/src/Android.mk -- out/target/product/flame/obj/SHARED_LIBRARIES /libfdio_intermediates/export_includes
>Import includes file: out/target/product/flame/obj/EXECUTABLES/bluetoothd_intermediates/import_includes
>target thumb C: bluetoothd <= system/bluetoothd/src/bt-av-io.c
>target thumb C: bluetoothd <= system/bluetoothd/src/bt-core-io.c
>system/bluetoothd/src/bt-core-io.c: In function 'register_bt_core':
>system/bluetoothd/src/bt-core-io.c:1507:5: error: initialization from incompatible pointer type [-Werror]
>system/bluetoothd/src/bt-core-io.c:1507:5: error: (near initialization for 'bt_callbacks.pin_request_cb') [-Werror]
>cc1: all warnings being treated as errors
>make: *** [out/target/product/flame/obj/EXECUTABLES/bluetoothd_intermediates/bt-core-io.o] Erreur 1
With some (very long) research, I found that it is caused by 'hardware/libhardware/include/hardware/bluetooth.h' file, at line related to "pin_request_callback". So, I modified the file like in Shawn patch :
> /** Bluetooth Legacy PinKey Request callback */
>+#ifdef Q_BLUETOOTH
> typedef void (*pin_request_callback)(bt_bdaddr_t *remote_bd_addr,
>                                         bt_bdname_t *bd_name, uint32_t cod, uint8_t secure);
>+#else
>+typedef void (*pin_request_callback)(bt_bdaddr_t *remote_bd_addr,
>+                                        bt_bdname_t *bd_name, uint32_t cod);
>+#endif
After that, I was able to build. So, I did these operations on my phone :
- flash gecko and gaia
- push /system/lib/libfdio.so and new /system/bin/bluetoothd
- modify boot image to insert init.bluetooth.rc, and import it (and remove old service bluetoothd/dbus in init.rc)

However, I'm still not able to use bluetooth on my device. When I try to enable bluetooth for first time (Settings > Bluetooth), the switch toggle off immediately, and I see this error on logcat :
>E/bluetoothd( 1379): hw_get_module failed: Unknown error -2
>I/GeckoBluetooth(  304): OnError: BluetoothInterface::Init failed: 1

At this stage, if I try to enable bluetooth a second time, the Settings app crash, and my Open C go back to Homescreen. Here is the associated logcat :
>I/GeckoBluetooth(  303): StartInternal: Error
>I/Gecko   (  303): IPDL protocol error: Handler for PBluetoothRequest returned error code
>I/Gecko   (  303):
>I/Gecko   (  303): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x22000A,name=PBluetooth::Msg_PBluetoothRequestConstructor) Processing error: message was deserialized, but the handler returned false (indicating failure)
>I/Gecko   (  303):
>I/Gecko   (  303): [Parent 303] WARNING: waitpid failed pid:1744 errno:10: file /home/compilation/B2G/gecko/ipc/chromium/src/base/process_util_posix.cc, line 267
>I/Gecko   (  303): [Parent 303] WARNING: pipe error (88): Connection reset by peer: file /home/compilation/B2G/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 459
>I/Gecko   (  303):
>I/Gecko   (  303): ###!!! [Parent][MessageChannel] Error: (msgtype=0x280080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
>I/Gecko   (  303):
>I/Gecko   (  303): [Parent 303] WARNING: pipe error (175): Connection reset by peer: file /home/compilation/B2G/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 459
>I/Gecko   (  303): [Parent 303] WARNING: pipe error (239): Connection reset by peer: file /home/compilation/B2G/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 459
>I/Gecko   (  303): XXX FIXME : Dispatch a mozChromeEvent: default-volume-channel-changed
>E/Sensors (  303): ---------------------als value = 64
>E/QCALOG  (  713): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
>E/QCALOG  (  713): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
>E/QCALOG  (  713): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
>E/GeckoConsole(  303): [JavaScript Error: "NS_ERROR_NOT_IMPLEMENTED: SetNFCFocus for in-process mode is not yet supported" {file: "jar:file:///system/b2g/omni.ja!/components/BrowserElementParent.js" line: 1170}]
>E/Sensors (  303): ---------------------als value = 97
In 'Device Information > More Information', Bluetooth Address is 00:00:00:00:00:00.
Hi
Please check if you have these files.
/system/lib/hw/audio.a2dp.default.so
/system/lib/libbt-utils.so
/system/lib/libbt-hci.so
/system/lib/hw/bluetooth.default.so

And you need to have libbt-vendor.so under /system/vendor/lib

For more information, you can check:
https://wiki.mozilla.org/B2G/Bluetooth-bluedroid
Hello Shawn,
>/system/lib/hw/audio.a2dp.default.so
OK
>/system/lib/libbt-utils.so
>/system/lib/libbt-hci.so
>/system/lib/hw/bluetooth.default.so
No for these 3 files.

>And you need to have libbt-vendor.so under /system/vendor/lib
I don't have this file in lib.

How can I get all of these files ?

>For more information, you can check:
>https://wiki.mozilla.org/B2G/Bluetooth-bluedroid
Thank you for this link. I found it few days ago, but I didn't understand all of the steps. I will read it again.
Flags: needinfo?(shuang)
While searching on CAF, I found this for libbt-vendor : https://www.codeaurora.org/cgit/quic/la/platform/hardware/qcom/bt/tree/?h=jb_3.2.5_rb1.7.
Is it ok for the Open C ?
(In reply to micgeri from comment #24)
> While searching on CAF, I found this for libbt-vendor :
> https://www.codeaurora.org/cgit/quic/la/platform/hardware/qcom/bt/tree/
> ?h=jb_3.2.5_rb1.7.
> Is it ok for the Open C ?
Hi,
It's possible to use this. But sometimes OEM modified their own version library.
It depends on how OEM customize qcom bluetooth driver.
Can you upload your boot.img which add init.bluetooth.rc? I can help to check rest of things.
Flags: needinfo?(shuang)
Comment on attachment 8690684 [details]
libbt-vendor.so

adb push libbt-vendor.so /system/vendor/lib/
Attached file libbtnv.so
adb push libbtnv.so /system/vendor/lib/
(In reply to micgeri from comment #20)
> After updating my repo with the modified xml file, and applying the patch,
> - push /system/lib/libfdio.so and new /system/bin/bluetoothd
> - modify boot image to insert init.bluetooth.rc, and import it (and remove
> old service bluetoothd/dbus in init.rc)
Hi
Can you provide the boot.img?

> 
> However, I'm still not able to use bluetooth on my device. When I try to
> enable bluetooth for first time (Settings > Bluetooth), the switch toggle
> off immediately, and I see this error on logcat :
> >E/bluetoothd( 1379): hw_get_module failed: Unknown error -2
> >I/GeckoBluetooth(  304): OnError: BluetoothInterface::Init failed: 1
>
Flags: needinfo?(mgperso)
(In reply to micgeri from comment #23)
> Hello Shawn,
> >/system/lib/hw/audio.a2dp.default.so
> OK
> >/system/lib/libbt-utils.so
> >/system/lib/libbt-hci.so
> >/system/lib/hw/bluetooth.default.so
> No for these 3 files.
> 

That explains why hw_get_module cannot load Bluetooth HAL library.
E/bluetoothd( 1379): hw_get_module failed: Unknown error -2
I/GeckoBluetooth(  304): OnError: BluetoothInterface::Init failed: 1

You need to adb push these files into your device after you built bluedroid.
Attached file Modified boot image
Hello Shawn,

Here is my modified boot.img file.
Flags: needinfo?(mgperso)
I pushed the libbt-vendor.so and libbtnv.so in my Open C.

>> >/system/lib/libbt-utils.so
>> >/system/lib/libbt-hci.so
>> >/system/lib/hw/bluetooth.default.so
>> No for these 3 files.
>> 
> 
>That explains why hw_get_module cannot load Bluetooth HAL library.
>E/bluetoothd( 1379): hw_get_module failed: Unknown error -2
>I/GeckoBluetooth(  304): OnError: BluetoothInterface::Init failed: 1
> 
>You need to adb push these files into your device after you built bluedroid.
Finally, I found these libs with './build.sh modules'
>./build.sh libbt-hci => out/target/product/flame/system/lib/libbt-utils.so and libbt-hci.so
>./build.sh bluetooth.default => out/target/product/flame/system/lib/hw/bluetooth.default.so
So, I pushed these files in the phone, and rebooted it. Now, if I try to enable bluetooth, it takes more time before toggle off, and the settings App don't crash anymore.

I attached the logcat.
Good news !

I found in my Open C a file named stack.conf, in /system/etc/bluetooth. This file only contained 'bluez'.
So I tried to replace bluez with bluedroid in the file, and rebooted the Phone.
> echo 'bluedroid' > /system/etc/bluetooth/stack.conf

Now, I can enable, and I can bluetooth address in 'Device Information > More Information'.
I successfully paired my phone with a 'Nokia 6700 classic' in both ways, and sent/received images also in both ways.

I have a question about bt_stack.conf, bt_did.conf, auto_pair_devlist.conf, and btd : are they necessary ?
(In reply to micgeri from comment #34)
> Good news !
> 
> I found in my Open C a file named stack.conf, in /system/etc/bluetooth. This
> file only contained 'bluez'.
> So I tried to replace bluez with bluedroid in the file, and rebooted the
> Phone.
> > echo 'bluedroid' > /system/etc/bluetooth/stack.conf
> 
> Now, I can enable, and I can bluetooth address in 'Device Information > More
> Information'.
> I successfully paired my phone with a 'Nokia 6700 classic' in both ways, and
> sent/received images also in both ways.
> 
> I have a question about bt_stack.conf, bt_did.conf, auto_pair_devlist.conf,
> and btd : are they necessary ?
If you do "mm" under external/bluetooth/bluedroid, you will get the following build logs:

Install: out/target/product/flame/system/etc/bluetooth/bt_stack.conf
Install: out/target/product/flame/system/etc/bluetooth/bt_did.conf
Install: out/target/product/flame/system/etc/bluetooth/auto_pair_devlist.conf
Install: out/target/product/flame/system/bin/bdt
Install: out/target/product/flame/system/lib/libbt-utils.so
Install: out/target/product/flame/system/lib/libbt-hci.so
Install: out/target/product/flame/system/lib/hw/bluetooth.default.so
Install: out/target/product/flame/system/lib/hw/audio.a2dp.default.so

These files are components of bluedroid stack.

bdt is actually for test you don't really need it. For the rest of config files are required.

Regarding stack.conf, that's CAF added config file to switch bluez and bluedroid.
Ok.
I have two other questions :
1) Is it possible to redistribute all of these files in a build ?
2) Also, is the libbtnv.so necessary, and which project provide source for him ?
(In reply to micgeri from comment #36)
> Ok.
> I have two other questions :
> 1) Is it possible to redistribute all of these files in a build ?
> 2) Also, is the libbtnv.so necessary, and which project provide source for
> him ?
(1) Only libbt-vendor.so, libbtnv.so (vendor specific files) are pulled from OpenC Android device, for the rest of bluedroid files are free to release without problem.
(2) We don't have source code, it's the part of QCT vendor library.
(In reply to Shawn Huang [:shawnjohnjr] from comment #37)
> (In reply to micgeri from comment #36)
> > Ok.
> > I have two other questions :
> > 1) Is it possible to redistribute all of these files in a build ?
> > 2) Also, is the libbtnv.so necessary, and which project provide source for
> > him ?
> (1) Only libbt-vendor.so, libbtnv.so (vendor specific files) are pulled from
> OpenC Android device, for the rest of bluedroid files are free to release
> without problem.
> (2) We don't have source code, it's the part of QCT vendor library.

Maybe you can follow: https://wiki.mozilla.org/B2G/Gonk
Whiteboard: [mozfr-community]
Hello Shawn,

I found a functionality that don't work in bluetooth with Open C and bluedroid. I connected my Acer laptop to my device, and tried to "play Open C music with my computer".
Normally, when you play song with the Music player on the phone, the sound should come out on the PC speaker.
Moreover, sometimes, the bluetooth refuse to disable correctly.
(In reply to micgeri from comment #39)
> Created attachment 8695560 [details]
> Comment 39 logcat - bluetooth audio and disable problem
> 
> Hello Shawn,
> 
> I found a functionality that don't work in bluetooth with Open C and
> bluedroid. I connected my Acer laptop to my device, and tried to "play Open
> C music with my computer".
> Normally, when you play song with the Music player on the phone, the sound
> should come out on the PC speaker.
> Moreover, sometimes, the bluetooth refuse to disable correctly.

After reviewing the log, this looks wrong. Do you use v2.5? I remember this is an old bug and been resolved long time ago. I will find the bug no, and get back to you.
 ../../../gecko/dom/bluetooth/bluedroid/BluetoothDaemonHelpers.cpp:908: Convert('ControlPlayStatus' to 'uint8_t') failed: aIn >= MOZ_ARRAY_LENGTH(sValue)
I/bluedroid(31441): get_profile_interface socket
I/bluedroid(31441): get_profile_interface handsfree
E/bt-btif (31441): btif_enable_service: current services:0x40
I/bluedroid(31441): get_profile_interface a2dp
D/btif_config_util(31441): btif_config_save_file(L153): in file name:/data/misc/bluedroid/bt_config.new
I/GKI_LINUX(31441): gki_task_entry: gki_task_entry task_id=2 [A2DP-MEDIA] starting
E/bt-btif (31441): btif_enable_service: current services:0x40040
I/bluedroid(31441): get_profile_interface avrcp
E/bluetoothd(31441): invalid service id 0x9

Oh. Wait. It looks like service id 0x9 is strange.
>After reviewing the log, this looks wrong. Do you use v2.5?
Yes, v2.5 for gecko/gaia. Also, I modified in the xml bluetoothd and libfdio revision to v2.5. When I built bluetoothd and libfdio, v2.5 and master branches were identical. Am I right ?

>I/bluedroid(31441): get_profile_interface socket
>I/bluedroid(31441): get_profile_interface handsfree
>E/bt-btif (31441): btif_enable_service: current services:0x40
>I/bluedroid(31441): get_profile_interface a2dp
>D/btif_config_util(31441): btif_config_save_file(L153): in file name:/data/misc/bluedroid/bt_config.new
>I/GKI_LINUX(31441): gki_task_entry: gki_task_entry task_id=2 [A2DP-MEDIA] starting
>E/bt-btif (31441): btif_enable_service: current services:0x40040
>I/bluedroid(31441): get_profile_interface avrcp
>E/bluetoothd(31441): invalid service id 0x9
> 
>Oh. Wait. It looks like service id 0x9 is strange.
I pushed/updated all needed files. What can be the reason for that ?
Flags: needinfo?(shuang)
(In reply to micgeri from comment #42)
> >E/bt-btif (31441): btif_enable_service: current services:0x40040
> >I/bluedroid(31441): get_profile_interface avrcp
> >E/bluetoothd(31441): invalid service id 0x9
> >Oh. Wait. It looks like service id 0x9 is strange.
> I pushed/updated all needed files. What can be the reason for that ?
Hi
Sorry for late reply, i'm in the middle of travling. I will check later next week.
Flags: needinfo?(shuang)
(In reply to Shawn Huang [:shawnjohnjr] from comment #43)
> (In reply to micgeri from comment #42)
> > >E/bt-btif (31441): btif_enable_service: current services:0x40040
> > >I/bluedroid(31441): get_profile_interface avrcp
> > >E/bluetoothd(31441): invalid service id 0x9
> > >Oh. Wait. It looks like service id 0x9 is strange.
> > I pushed/updated all needed files. What can be the reason for that ?
> Hi
> Sorry for late reply, i'm in the middle of travling. I will check later next
> week.

Hello Shawn,
Ok
Hello Shawn,

Have you got informations about the reason of this strangeness ?
Flags: needinfo?(shuang)
I accidentally found a way to activate Audio Speaker with my acer :
- Pair the Open C with the acer laptop
- Connect phone speaker (audio speaker is not necessary)
- Disable bluetooth on the phone
- Enable bluetooth on the phone

The logcat of these steps is in the attachment.
Also included the error occuring at enabling/disabling bluetooth audio speaker.
Attachment #8695560 - Attachment is obsolete: true
(In reply to micgeri from comment #46)
> Created attachment 8705441 [details]
> test bluetooth audio openc.txt
> 
> I accidentally found a way to activate Audio Speaker with my acer :
> - Pair the Open C with the acer laptop
> - Connect phone speaker (audio speaker is not necessary)
> - Disable bluetooth on the phone
> - Enable bluetooth on the phone
> 
> The logcat of these steps is in the attachment.
> Also included the error occuring at enabling/disabling bluetooth audio
> speaker.

Hi
Do you see the same problem with regular Bluetooth A2DP speaker/headset?
I never tried to connect with computer which acts as A2DP speaker. What's the OS of your Acer? Is it Windows 7?
Flags: needinfo?(shuang) → needinfo?(biio)
Hello Shawn,(In reply to Shawn Huang [:shawnjohnjr] from comment #47)
> (In reply to micgeri from comment #46)
> > Created attachment 8705441 [details]
> > test bluetooth audio openc.txt
> > 
> > I accidentally found a way to activate Audio Speaker with my acer :
> > - Pair the Open C with the acer laptop
> > - Connect phone speaker (audio speaker is not necessary)
> > - Disable bluetooth on the phone
> > - Enable bluetooth on the phone
> > 
> > The logcat of these steps is in the attachment.
> > Also included the error occuring at enabling/disabling bluetooth audio
> > speaker.
> 
> Hi
> Do you see the same problem with regular Bluetooth A2DP speaker/headset?
> I never tried to connect with computer which acts as A2DP speaker. What's
> the OS of your Acer? Is it Windows 7?

Hello Shawn,

Windows 7, indeed.
When you said regular speaker/headset, were you talking about Bluetooth headset, or cars ?
(The answer was given by micgeri)
Flags: needinfo?(biio)
Hello Shawn,

During the weekend, I had the opportunity to test my device with a bluetooth headset.
When I connected my phone to the headset, it worked immediately.

Also, I am testing libbt-vendor.so built from CAF source (please see Comment 24), and it seems to work correclty. It's also true for AOSP source, revision android-4.3_r3 (testing since this saturday) : https://android.googlesource.com/platform/hardware/qcom/bt/+/android-4.3_r3/.
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.