Can't edit livemarks

RESOLVED FIXED in seamonkey2.41

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: neil, Assigned: neil)

Tracking

unspecified
seamonkey2.41

SeaMonkey Tracking Flags

(seamonkey2.40 fixed, seamonkey2.41 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Because bug 1165316 missed two cases.
(Assignee)

Comment 1

3 years ago
Created attachment 8672415 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8672415 - Flags: review?(philip.chee)
Attachment #8672415 - Flags: review?(iann_bugzilla)

Comment 2

3 years ago
Comment on attachment 8672415 [details] [diff] [review]
Proposed patch

r=me

> -          PlacesUtils.livemarks.getLivemark({ id: this._itemId }, this);
> +          PlacesUtils.livemarks.getLivemark({ id: this._itemId })
> +                               .then(aLivemark => {
> +            this._itemType = LIVEMARK_CONTAINER;
> +            this._feedURI = aLivemark.feedURI;
> +            this._siteURI = aLivemark.siteURI;
> +            this._fillEditProperties();
> +
> +            document.documentElement
> +                    .getButton("accept").disabled = !this._inputIsValid();
> +            window.outerHeight += this._element("nameRow").boxObject.height * 2;
> +          }, () => undefined);
> +
Unnecessary blank line.

Also when I tried to subscribe to a feed the feed preview menulist drop down popupmenu is transparent like it's missing some css (broken is classic, working in modern).
Attachment #8672415 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 3

3 years ago
(In reply to Philip Chee from comment #2)
> Unnecessary blank line.
Oops.

> Also when I tried to subscribe to a feed the feed preview menulist drop down
> popupmenu is transparent like it's missing some css (broken is classic,
> working in modern).
Bug 1211708.

Comment 4

3 years ago
Comment on attachment 8672415 [details] [diff] [review]
Proposed patch

r=me with Ratty's change addressed.
Attachment #8672415 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 5

3 years ago
Pushed comm-central changeset deac832faa42.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.41
(Assignee)

Comment 6

3 years ago
Comment on attachment 8672415 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 1094900
String changes made by this patch: None
Attachment #8672415 - Flags: approval-comm-aurora?

Updated

3 years ago
Attachment #8672415 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 7

3 years ago
Pushed comm-beta changeset 3c5164cb2013.
status-seamonkey2.40: --- → fixed
status-seamonkey2.41: --- → fixed
You need to log in before you can comment on or make changes to this bug.