[DOGFOOD] Scroll bar is messed up and hard to scroll to end of list

VERIFIED FIXED in M10

Status

SeaMonkey
MailNews: Message Display
P3
major
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Suresh, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview Description:  The scroll bar is messed up. When Messenger is launched
it shows up in the right place. But when I scroll down to read the last message,
the scroll bar comes up at a different location (inbetween Folder pane and
Message pane).

Steps to Reproduce:
1. Start Messenger using Task | Messenger.
2. Scroll down to read the last message. (Note: You have to re-size the window
to see the scroll bar).
3. The scroll bar comes up at a different location.

Build Date & Platform Bug Found:
8/19/99 Windows debug build. I pulled the tree around 10.00 AM.

Comment 1

19 years ago
I think this is a duplicate of another bug.

Comment 2

19 years ago
Suresh - does the description in
http://bugzilla.mozilla.org/show_bug.cgi?id=10426 and
http://bugzilla.mozilla.org/show_bug.cgi?id=10638 fit what you're seeing?
(Reporter)

Comment 3

19 years ago
I don't think so. Looks like bug#10426 occurs only when Maximizing Messenger
Window and the scroll bar stays at place eventhough it should have been moved to
the far right. But in this bug, whenever I scroll down, scroll bar appears
inbetween Folder Pane and Message pane. I need to resize the window to actually
see "down arrow" to scroll down. Very strange :-(.

Updated

19 years ago
Assignee: putterman → hyatt

Comment 4

19 years ago
reassigning to hyatt.

Updated

19 years ago
Blocks: 11091
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: Scroll bar is messed up. → [DOGFOOD] Scroll bar is messed up.
Target Milestone: M10

Comment 5

19 years ago
Update:  This was tested in Scott Puttterman's cube with an M10 build that has f
fix for the crash when mousing over the scroll bar.  This bug is new and
different from the bugs mentioned above.  A list of the annoying behaviour:
1. The scroll bar moves over to the left side of the Thread pane when you
finally get to the bottom of the thread list using the down arrow.
2. The grabber inside the scroll bar doesn't respond to dragging down to display
messages at the bottom of the thread list.
3. If you do use the grabber in the scroll bar, the messages seem to roll up and
down, sometimes repeating the list.
4. To get to the bottom of the list of messages, the user has to click the down
arrow for each message to move them one at a time.  This is very time consuming.

Updated

19 years ago
Blocks: 12176
No longer blocks: 11091
Severity: normal → major
Summary: [DOGFOOD] Scroll bar is messed up. → [DOGFOOD] Scroll bar is messed up and hard to scroll to end of list

Comment 6

19 years ago
due to 2, 3, 4 cited above, I am raising the severity.
Dogfood bug is actually 12176 so changing dependency.

Updated

19 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 7

19 years ago
Using 1999082616 M10 on Mac, and Linux build 1999082906 M10 the scrool bar has
this problem too (note: the linux build has a date later than the timestamp on
this comment, the directory and date are wrong I took the build at 2:00 8/27)
Changing to Platform and OS to All
Also note: if the flaky scroll bar is used too much, you end up crashing (see
bug 12645).
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
Fixed.

Comment 9

19 years ago
Using 1999100617M10 commercial build on win98 and 1999100615M10 commercial build
on mac this is fixed.  Waiting for linux to verify for that platform.

Updated

19 years ago
No longer blocks: 12176

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Linux (1999-10-20-11 M11) commercial
Win NT (1999-10-20-11 M11) commercial
Mac (1999-10-20-11 M11) commercial
Using the same scenario as described in the original report, I do not see the
problem. It must be fixed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.