If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Dogfood] Using scroll bar in Messenger causes crash - folder pane

VERIFIED FIXED in M11

Status

MailNews Core
Backend
P1
critical
VERIFIED FIXED
18 years ago
8 months ago

People

(Reporter: esther, Assigned: scottputterman)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using 1999082617 M10 build on Win98, Scroll bar is acting up and usage causes a
crash.  As stated in bug 12140 the scroll bar will flip back and forth from
right to left side of pane when you have moved the slider to the bottom.  When
this happens, if you click on the arrows at the top and bottom of the scroll bar
when it's on the left side, it move back to the right side.  Continuing this
will eventually lead to a crash.  I have 3 talkback report, but the server seems
to be down and not receiving them at this time.  When I get them I will post the
incident number and stack.  Still need to check linux and mac.

1. Launch Messenger (using apprunner -mail) (have at least 3 accounts so you can
fill the Folder pane)
2. Expand folders in the folder pane to force the scroll bar to display
3. Keep  expanding folders, then click on the down arrow of the scroll bar so
the scroll bar moves to the left side of the pane.
4. Click on the scroll bar on the left side (continuously until it moves back to
the right side).
5. Continue steps 2,3,4 randomly until you crash (usually withing 2 minutes).

Updated

18 years ago
Summary: Using scroll bar in Messenger causes crash → Using scroll bar in Messenger causes crash - folder pane

Updated

18 years ago
Blocks: 12176
(Reporter)

Updated

18 years ago
OS: Windows 98 → All
Hardware: PC → All
(Reporter)

Comment 1

18 years ago
The last linux build on the 26th crashes when mousing over the scroll bar (which
means is it is the build that has bug 12534) and the 27 build doesn't launch,
so I will have to wait for another build to test linux.   Mac build 999082614
displays the same scroll bar flakiness and takes more to crash, but it does
crash.  A talkback incident will be noted when it is received.   Changing to
All.
(Reporter)

Comment 2

18 years ago
I took the latest linux build dated 1999082906 M10 it crashes too (note: the
linux build has a date later than the timestamp on this comment, the directory
and date are wrong I took the build at 2:00 8/27)
(Reporter)

Comment 3

18 years ago
Another update... took the newest 8/27 builds on win98 (1999082712M10), linux
(1999082705M10) and mac (1999082712M10) this still happens.  Talkback still
isn't receiving incidents so I will sent one when I get it in.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Comment 4

18 years ago
Fixed.  Note that there still is a scrollbar crash (caused by scrolling up
rapidly), but this crash is different and has been fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 5

18 years ago
Using build 19990914 on win98 & NT4.0, and linux (mac not tested yet) this still
crashes.  It doesn't crash when you scroll by dragging the bar up and down, but
when you click the down or up arrows for the scroll bar it crashes.  Reopening
this bug
(Reporter)

Updated

18 years ago
Resolution: FIXED → ---

Updated

18 years ago
Summary: Using scroll bar in Messenger causes crash - folder pane → [Dogfood] Using scroll bar in Messenger causes crash - folder pane

Comment 6

18 years ago
M10 has passed - pls assign a new target milestone. Thanks.

Comment 7

18 years ago
hyatt or trudelle, is the remaining part of this bug an issue for evaughan?

Updated

18 years ago
Priority: P3 → P1
Target Milestone: M10 → M11

Comment 8

18 years ago
setting p1 for m11

Updated

18 years ago
Blocks: 11091
No longer blocks: 12176

Comment 9

18 years ago
changing dependency bug to the beta tracking bug

Comment 10

18 years ago
My hands have deteriorated to the point where I can no longer type.  I need
help.  If you think you can fix this bug on your own, please take it away from
me.  If you'd like to volunteer to be my hands for a specific bug, then I'll be
happy to come up to your cube and sit with you and fix the bug (assuming you
have the patience for that).

Comment 11

18 years ago
Dave, being a manager, I have no important work to do, so I volunteer to be your
hands. My tip build is about an hour from being done.
(Assignee)

Updated

18 years ago
Assignee: hyatt → putterman
Status: REOPENED → NEW
(Assignee)

Comment 12

18 years ago
I will look into this one.  I will probably be by for some pointers.

Comment 13

18 years ago
One cause of this crash was a dereference of a null pointer in
layout\base\src\nsGenericElement.cpp in the following code:

nsGenericElement::Release()
{
  nsrefcnt rc=0;
  NS_ASSERTION(mContent, "nsGenericElement: Nothing to release!");
  if (mContent)
    NS_RELEASE2(mContent, rc);
  return rc;

AlecF fixed this code to check mContent before releasing - I wonder if that's
what people were seeing re a crash scrolling.
(Assignee)

Comment 14

18 years ago
Yeah, probably.  It's asserting now which is much better than crashing but still
pretty annoying for a debug build.

Comment 15

18 years ago
so the problem still exists.
Strangely, I don't see this assertion anymore on Unix.

Comment 16

18 years ago
It still happens in the folder pane on windows - it doesn't happen in the thread
pane, at least for me.
(Assignee)

Updated

18 years ago
Blocks: 15008
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

18 years ago
I checked in a fix for the assertion.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 18

18 years ago
Linux (1999-10-20-11 M11) commercial
Win NT (1999-10-20-11 M11) commercial
Mac (1999-10-20-11 M11) commercial
I do not see the scroll bar move to left and to right any more.  And I do not
see any crash using the scenario as described. However I am seeing Linux crashes
when I drag the scroll bar up and down for a period of time. Will write another
bug for that parity bug.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.