Refresh Sync key based on 'services.sync.enabled' pref

RESOLVED DUPLICATE of bug 1211606

Status

Firefox OS
Sync
--
major
RESOLVED DUPLICATE of bug 1211606
2 years ago
2 years ago

People

(Reporter: ferjm, Assigned: ferjm)

Tracking

(Blocks: 1 bug)

unspecified
FxOS-S9 (16Oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
Right now if the 'services.sync.enabled' pref is not enabled, we don't ask for the Sync keys when login into Firefox Accounts. Because we default 'services.sync.enabled' to false and we login into FxA *before* login into Sync, we never ask for the Sync keys. That's bad.

We need a way to ask the FxA client to fetch the keys when the value of 'services.sync.enabled' is set to true.
(Assignee)

Updated

2 years ago
Assignee: nobody → ferjmoreno
Blocks: 824026
Depends on: 1211606
Target Milestone: --- → FxOS-S9 (16Oct)
(Assignee)

Comment 1

2 years ago
This won't be needed after bug 1211606
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1211606
You need to log in before you can comment on or make changes to this bug.