[New Homescreen] Launching an app and then switching to the new home screen will result in randomly missing app icons

RESOLVED DUPLICATE of bug 1211266

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1211266
2 years ago
2 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe], URL)

Attachments

(1 attachment)

Launching an app using the old home screen and then switching to the new home screen will result in randomly missing apps. This is different than bug 1213233
where all icons on the homescreen are missing.

Repro Steps:
1) Update a Aries to 20151012110146
2) Flash the device to the latest build and complete the FTU.
3) After reaching the homescreen, launch the contacts app.
4) Go home, go to settings and switch to the new homescreen.
5) Observe all the icons on the homescreen.

Actual:
There will be randomly missing icons on the new homescreen.

Expected:
All icons appear correctly.

Environmental Variables:
Device: Aries 2.5
Build ID: 20151012110146
Gaia: 87f5c9d55ab6a77dcfa48a3f3a8b4f5016f3c657
Gecko: 0b69d304f861d0038fb78f1d52b0f5d13ef7c6fe
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 5/5 100%
See attached: logcat, video

Comment 1

2 years ago
Sounds like bug 1211266
(Reporter)

Updated

2 years ago
Blocks: 1191745
status-b2g-master: --- → affected
Whiteboard: [2.5-Daily-Testing][Spark][Systemsfe]
Where is the logcat? I concurr to :cwiiis, it's probably a dupe.
Flags: needinfo?(ktucker)
Created attachment 8673215 [details]
MissingiconsLogcat
Flags: needinfo?(ktucker)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1211266
(Reporter)

Updated

2 years ago
(Reporter)

Updated

2 years ago
QA Whiteboard: [ → [QAnalyst-Triage+]
(Reporter)

Updated

2 years ago
Blocks: 1214349
(Reporter)

Updated

2 years ago
No longer blocks: 1214349
You need to log in before you can comment on or make changes to this bug.