Closed Bug 1214496 Opened 7 years ago Closed 7 years ago

Use localStorage instead of asyncStorage in History adapter

Categories

(Firefox OS Graveyard :: Sync, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1207468
FxOS-S11 (13Nov)

People

(Reporter: selee, Assigned: selee)

References

Details

localStorage[1] is easier to store the revision ID for the last synced status[2] than asyncStorage extra loaded.

[1] https://developer.mozilla.org/en-US/docs/Web/API/Window/localStorage
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/sync/js/adapters/history.js#L45
Assignee: nobody → selee
Status: NEW → ASSIGNED
Target Milestone: --- → FxOS-S11 (13Nov)
I'll do this at the same time as bug 1207468.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207468
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.