Closed Bug 1214713 (SQLite3.9.1) Opened 4 years ago Closed 4 years ago

Upgrade to SQLite 3.9.1

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox44 --- fixed

People

(Reporter: ionnv, Assigned: RyanVM)

References

()

Details

Attachments

(1 file)

https://www.sqlite.org/news.html

https://www.sqlite.org/releaselog/3_9_0.html

"SQLite version 3.9.0 is a regularly schedule maintenance release. Key changes include:

    Begin using semantic versioning.
    JSON SQL functions
    The FTS5 full-text search engine
    Support for indexes on expressions
    Support for table-valued functions 

See the change log for a long and more complete list of changes. "
Depends on: SQLite3.8.11.1
Thanks for filing.
Alias: Sqlite3.9.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mak says there's no rush on this, so I'll take this next week on the off chance there are any critical issues found in the mean time. I did a Try run for drh a few days ago of a recent amalgamation without issue, so I don't expect this to have any landing difficulties.
Assignee: nobody → ryanvm
Alias: Sqlite3.9.0 → Sqlite3.9.1
Summary: Upgrade to SQLite 3.9.0 → Upgrade to SQLite 3.9.1
Do we want to enable json1 or FTS5 by default or save them for another bug?
Flags: needinfo?(mak77)
Alias: Sqlite3.9.1 → SQLite3.9.1
Vanilla 3.9.1 is looking good on Try (and fine locally).
https://treeherder.mozilla.org/#/jobs?repo=try&revision=398f5fa40dde&group_state=expanded
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #3)
> Do we want to enable json1 or FTS5 by default or save them for another bug?

We don't enable features until someone in the project actually needs them with good reasons.
Flags: needinfo?(mak77)
Good on Try, good tested locally, and seems to be sticking upstream. Let's get this landed.
Attachment #8676829 - Flags: review?(mak77)
Comment on attachment 8676829 [details] [diff] [review]
Upgrade to SQLite 3.9.1

Review of attachment 8676829 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you
Attachment #8676829 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/836d8a2ea713
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Blocks: SQLite3.9.2
Blocks: SQLite3.10.1
You need to log in before you can comment on or make changes to this bug.