Closed Bug 1220890 (SQLite3.9.2) Opened 7 years ago Closed 7 years ago

Upgrade to SQLite 3.9.2

Categories

(Toolkit :: Storage, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ionnv, Unassigned)

References

()

Details

https://www.sqlite.org/news.html

https://www.sqlite.org/releaselog/3_9_2.html

"SQLite version 3.9.2 is a patch release fixing two obscure bugs. (Details: (1), (2)). Upgrade only if you are having problems."
Depends on: SQLite3.9.1
The fixes in question:

* Fix the schema parser so that it interprets certain (obscure and ill-formed) CREATE TABLE statements the same as legacy. Fix for ticket ac661962a2aeab3c33
* Fix a query planner problem that could result in an incorrect answer due to the use of automatic indexing in subqueries in the FROM clause of a correlated scalar subqueries. Fix for ticket 8a2adec1.

I'll spin a patch up if you think it's worth it, Marco. Otherwise, happy to wontfix it otherwise.
Flags: needinfo?(mak77)
I don't think we are affected by those 2 obscure schema bugs, I think we can skip this version.
Thank you for the heads up.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(mak77)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.