Closed Bug 1215208 Opened 7 years ago Closed 7 years ago

[e10s] scrolling with mouse wheel is too fast

Categories

(Core :: Panning and Zooming, defect)

All
Windows 8.1
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1153156

People

(Reporter: ratm6, Unassigned)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0 Cyberfox/41.0.2
Build ID: 20150930225852

Steps to reproduce:

I installed firefox 43 developer edition (64 bit but it's the same with 32 bit).
I opened a webpage (any webpage has the bug).
I scrolled up and down with the mouse wheel.


Actual results:

The scrolling was very fast, compared with when multiprocess is disabled.


Expected results:

Scrolling should be normal, just like if multiprocess was disabled.
I attached two short videos so you can compare the scrolling.
OS: Unspecified → Windows 8.1
Hardware: Unspecified → All
It's  not obvious on the videos but I promise there's a big difference between them.
Just download the videos, watch them with VLC for instance then see the speed of the scrolling bar on the right of the screen.
Blocks: e10s
Severity: normal → major
Status: UNCONFIRMED → NEW
tracking-e10s: --- → ?
Ever confirmed: true
Keywords: regression
Summary: scrolling with mouse wheel is too fast with multiprocess enabled → [e10s] scrolling with mouse wheel is too fast
Version: 43 Branch → Trunk
See Also: → 1182435
I wonder whether this is fixed by APZ. Can you try setting the pref layers.async-pan-zoom.enabled to true in about:config (+restarting)?
Just a guess, we might be missing a DPI conversion when sending the wheel event to the child process.
(In reply to Markus Stange [:mstange] from comment #6)
> Just a guess, we might be missing a DPI conversion when sending the wheel
> event to the child process.

On Windows, scroll wheel delta values are by lines or by pages. So, converting from them to pixels are done in EventStateManager:
http://mxr.mozilla.org/mozilla-central/source/dom/events/EventStateManager.cpp?rev=41dea9df27ed&mark=2491-2497,2575-2577#2488

I have no idea why this depends on the process type...
(In reply to Markus Stange [:mstange] from comment #5)
> I wonder whether this is fixed by APZ. Can you try setting the pref
> layers.async-pan-zoom.enabled to true in about:config (+restarting)?

With APZ enabled, it's scrolling slower. But the Flash video that is the webpage is bugging seriously when this parameter is set to True. Watch the small video I've made and attached...
Also, please notice the big visual bug that happens with Firefox 43 (e10s on or off), look at the elements at the top and at the bottom of the webpage in the videos, they hang alone absurdly.

Try to go to www.free.fr with firefox 41 you'll see they is no problem like this! ^^

Tell me : should I open another bug report about that hanging elements?
Thanks !
What's your wheel scroll size in Windows mouse settings? 

https://i.imgur.com/qsxg0ZG.jpg

Try using the default value of 3 and compare e10s on and off.
(In reply to Kestrel from comment #11)
> What's your wheel scroll size in Windows mouse settings? 
> 
> https://i.imgur.com/qsxg0ZG.jpg
> 
> Try using the default value of 3 and compare e10s on and off.

My wheel scroll size is 6.
When I try to scroll firefox 43 with the default value (3), I get a normal scrolling not too fast with e10s on or off.

But that doesn't solve the problem! I'd like to keep the value of 6 in order to be faster in Windows and in other softwares! 
Firefox' e10s doesn't support the value of 6, this is the problem.
(In reply to Julien from comment #12)

> I'd like to keep the value of 6 in order to be faster in Windows and in other softwares!

Same here. Sounds like a duplicate of bug 1153156.
(In reply to Kestrel from comment #13)
> (In reply to Julien from comment #12)
> 
> > I'd like to keep the value of 6 in order to be faster in Windows and in other softwares!
> 
> Same here. Sounds like a duplicate of bug 1153156.

I don't think so. Bug 1153156 is system scroll speed overriding issue. The cause is nsBaseWidget::OverrideSystemMouseScrollSpeed() is performed in the content process instead of nsWindow::OverrideSystemMouseScrollSpeed() due to the widget in content process is PuppetWidget.
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #14)
> I don't think so.

Bug 1153156 has the same characteristics; scrolling is too fast, related to e10s, only happens with custom system scroll size.

(In reply to Julien from comment #12)
> When I try to scroll firefox 43 with the default value (3), I get a normal
> scrolling not too fast with e10s on or off.
Incidentally, with all Windows settings at default and a fresh install of Firefox Nightly, the opposite is true for me.  My scrolling in Firefox is painfully slow.  Almost unusable.  I have to literally hammer my mousewheel to get anywhere at all.  

I created a bug regarding the jarring scroll animation differences between Firefox/Windows 10 Apps but it appears to be more than simply an animation physics difference.

https://bugzilla.mozilla.org/show_bug.cgi?id=1216934
Julien, could you please post your about:support text so we can take a look at your settings and prefs? Thanks.
Flags: needinfo?(ratm6)
Depends on: 1153156
(In reply to Jim Mathies [:jimm] from comment #17)
> Julien, could you please post your about:support text so we can take a look
> at your settings and prefs? Thanks.

Here it is : 
"Paramètres de base de l'application
-----------------------------------

Nom: Firefox
Version: 43.0a2
Identifiant de compilation: 20151027004102
Canal de mise à jour: aurora
Agent utilisateur: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Fenêtres multi-processus: 1/1 (par défaut : true)
Mode sans échec: false

Rapports de plantage des 3 derniers jours
-----------------------------------------

Tous les rapports de plantage

Extensions
----------

Accélération graphique
----------------------

Date du pilote: 3-16-2015
Date du pilote (GPU 2): 9-23-2013
Description de la carte: IGFX
Description de la carte (GPU 2): Radeon (TM) HD 8670M
Direct2D activé: true
DirectWrite activé: true (6.3.9600.17999)
Fenêtres avec accélération graphique: 1/1 Direct3D 11 (OMTC)
GPU 2 actif: false
ID du périphérique: 0x0416
ID du périphérique (GPU 2): 0x6660
ID du sous-système: 1978103c
ID du sous-système (GPU 2): 21af103c
ID du vendeur: 0x8086
ID du vendeur (GPU 2): 0x1002
Pilote de la carte (GPU 2): aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Pilotes de la carte: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Prise en charge matérielle pour le décodage H264: Yes
RAM de la carte: Unknown
RAM de la carte (GPU 2): 1024
Rendu WebGL: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
Version du pilote: 10.18.14.4170
Version du pilote (GPU 2): 13.151.2.0
windowLayerManagerRemote: true
Zoom/Panoramique asynchrones: aucun
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Préférences modifiées importantes
---------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20151027004102
browser.startup.homepage_override.buildID: 20151027004102
browser.startup.homepage_override.mstone: 43.0a2
browser.tabs.remote.autostart: true
browser.tabs.remote.autostart.2: false
browser.tabs.warnOnClose: false
browser.urlbar.suggest.searches: true
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 43.0a2
gfx.crash-guard.d3d11layers.appVersion: 43.0a2
gfx.crash-guard.d3d11layers.deviceID: 0x0416
gfx.crash-guard.d3d11layers.driverVersion: 10.18.14.4170
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d9video: 2
gfx.crash-guard.status.glcontext: 2
gfx.direct3d.last_used_feature_level_idx: 0
media.gmp-eme-adobe.abi: x86_64-msvc
media.gmp-eme-adobe.lastUpdate: 1445777359
media.gmp-eme-adobe.version: 15
media.gmp-gmpopenh264.abi: x86_64-msvc
media.gmp-gmpopenh264.lastUpdate: 1445777360
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20151027004102
media.gmp-manager.lastCheck: 1445963363
media.hardware-video-decoding.failed: false
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Préférences verrouillées importantes
------------------------------------

JavaScript
----------

Ramasse-miettes incrémentiel: true

Accessibilité
-------------

Activée: false
Empêcher l'accessibilité: 0

Versions des bibliothèques
--------------------------

NSPR
Version minimale attendue: 4.10.10
Version utilisée: 4.10.10

NSS
Version minimale attendue: 3.20.1 Basic ECC
Version utilisée: 3.20.1 Basic ECC

NSSSMIME
Version minimale attendue: 3.20.1 Basic ECC
Version utilisée: 3.20.1 Basic ECC

NSSSSL
Version minimale attendue: 3.20.1 Basic ECC
Version utilisée: 3.20.1 Basic ECC

NSSUTIL
Version minimale attendue: 3.20.1
Version utilisée: 3.20.1

Fonctionnalités expérimentales
------------------------------
"
Flags: needinfo?(ratm6)
Flags: needinfo?(jmathies)
This is unrelated to e10s. Nightly has apz enabled, aurora doesn't. Comparing the two on http://portail.free.fr/ I see that apz scrolls farther, faster than non-apz. This is something I've gotten use to on nightly, but I can see how users might notice it when switching.
Blocks: apz-desktop
No longer blocks: e10s
Component: Untriaged → Panning and Zooming
Flags: needinfo?(jmathies)
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1153156
You need to log in before you can comment on or make changes to this bug.