Closed Bug 1215379 Opened 6 years ago Closed 1 year ago

about:debugging items should include means to pause a worker on service worker load in debugger

Categories

(DevTools :: about:debugging, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1545650

People

(Reporter: akratel, Unassigned)

References

(Blocks 1 open bug)

Details

When selecting a SW for debugging in about:debugging, one should be able to select an option so that the SW is paused in debugger at SW load.
Blocks: 1214248
Blocks: 1209369
Great improvement idea! But not required for Developer Edition 47.
No longer blocks: 1214248
Priority: -- → P2
Mentor: janx
Decreasing the priority to P3, because break-on-worker-start is a nice feature to have, but there are more important worker-debugging issues to address first.

If someone would like to address this however, I'd be happy to mentor the effort, and assist with any questions.
Priority: P2 → P3
Blocks: 1279577
Component: Developer Tools: Debugger → Developer Tools: about:debugging
Mentor: janx
Product: Firefox → DevTools

Pulling into new worker debugging UI.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1545650
You need to log in before you can comment on or make changes to this bug.