Closed Bug 1215471 Opened 5 years ago Closed 5 years ago

[Contacts] The attachment file name shows "NaN MB" when user attaches a contact in Messages

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: lixia, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.5-aries-test-run-3])

Attachments

(5 files)

[1.Description]:
[Aries KK v2.5][Flame KK v2.5][Message]When user adds a contact attachment by selecting "Communications", it is shown as "NaN MB", and the attachment has no response when user taps on it.

Found at: 14:50
Attach: Aries_v2.5.3gp and logcat_1450.txt.

[2.Testing Steps]: 
1. Launch Message.
2. Create a new message.
3. Add attachment by selecting "Communications" and then select a contact.
4. Observe the contact attachment and tap on it.

[3.Expected Result]: 
4. It should be shown as a ".vcf" file, and "View/Remove attachment/Replace attachment" option menu will pop up when user taps on it.

[4.Actual Result]: 
4. It is shown as "NaN MB", and it has no response when user taps on it.

[5.Reproduction build]: 
Device: Flame KK 2.2 (unaffected) 
Build ID               20151015032552
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/fcd242553d92
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151015.070319
Firmware Date          Thu Oct 15 07:03:28 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (affected)
Build ID               20151015150343
Gaia Revision          8ea9029190af2ffeb04dcd97b323738125e31a0e
Gaia Date              2015-10-15 14:30:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d374d16cbb251c9dac5af69f8e186e821ce82fe2
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151015.183044
Firmware Date          Thu Oct 15 18:30:54 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (affected)
Build ID               20151015193337
Gaia Revision          8ea9029190af2ffeb04dcd97b323738125e31a0e
Gaia Date              2015-10-15 14:30:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d374d16cbb251c9dac5af69f8e186e821ce82fe2
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151015.185317
Firmware Date          Thu Oct 15 18:53:25 UTC 2015
Bootloader             s1


[6.Reproduction Frequency]: 
Always Recurrence,6/6

[7.TCID]: 
Free Test

[8.Note]:
The .vcf file in message shows normally when user adds the contact attachment by sharing contact in contact app.
Attached video Aries_v2.5.3gp
Attached file logcat_1450.txt
Summary: [Message]This "Communications" attachment is broken/abnormal and shown as "NaN MB". → [Message] The attachment file name shows "NaN MB" when user attaches a contact
[Blocking Requested - why for this release]:

Basic functionality is broken.
Nominate it.
blocking-b2g: --- → 2.5?
Agreed it should block.

Is it different when we share the contact from the Contacts app and choose Messages ?
Flags: needinfo?(lixia)
Keywords: qawanted
This issue is not occurring when sharing a contact from Contacts and choosing Messages. Screenshot attached.
Result: Contact file appears as (name).vcf

Environmental Variables:
Device: Aries 2.5 Kk
BuildID: 20151016122951
Gaia: 8999f0ba6326d815c8366e3c1155b7e4e9763b40
Gecko: ccf288f658211b6cfab33c458aaf033baed2375b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Seems I can't attach contact in Email as well. I see the following error in logcat:

W/Communications( 5228): [JavaScript Warning: "Sending message that cannot be cloned. Are you trying to send an XPCOM object?" {file: "jar:file:///system/b2g/omni.ja!/components/ActivityRequestHandler.js" line: 52}]

In Messages, activity.result is clearly wrong, both name and blob are corrupted.

Forwarding to Contacts.
Component: Gaia::SMS → Gaia::Contacts
Summary: [Message] The attachment file name shows "NaN MB" when user attaches a contact → [Contacts] The attachment file name shows "NaN MB" when user attaches a contact in Messages
Let's try to find a culprit first.
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK v2.5
Build ID               20151012071910
Gaia Revision          8b79556de1e0d602650b985a2b0af9c86b528c05
Gaia Date              2015-10-12 13:29:07
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/b3df0fc12543f5b4a8ed6297bf5c4884cecdf2b9
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151006.182813
Firmware Date          Tue Oct  6 18:28:25 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Build ID               20151012085911
Gaia Revision          87a208aa1d136f3adebec82330f2156eee2bfca8
Gaia Date              2015-10-12 15:19:54
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/a89ac66333b613effea9773eaa2ba12d8eb942a4
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151006.182813
Firmware Date          Tue Oct  6 18:28:25 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          87a208aa1d136f3adebec82330f2156eee2bfca8
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/b3df0fc12543f5b4a8ed6297bf5c4884cecdf2b9

First Broken Gecko & Last Working Gaia – issue DOES NOT repro
Gaia Revision          8b79556de1e0d602650b985a2b0af9c86b528c05
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/a89ac66333b613effea9773eaa2ba12d8eb942a4

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/8b79556de1e0d602650b985a2b0af9c86b528c05...87a208aa1d136f3adebec82330f2156eee2bfca8


Hi Zibi,

    This bug is probably caused by Bug 1212151, could you help to check?  

Thank you.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(gandalf)
Assignee: nobody → gandalf
Flags: needinfo?(gandalf)
Comms triage: Functional regression
Assignee: gandalf → nobody
Blocks: 1212151
blocking-b2g: 2.5? → 2.5+
Comment on attachment 8675562 [details] [review]
[gaia] zbraniecki:1215471-fix-a-regression-introduced-by-patch-from-bug-1212151 > mozilla-b2g:master

Not sure how I missed it. I'm pretty sure that there's no more leftovers after grepping everything for "VCardFileName".
Attachment #8675562 - Flags: review?(borja.bugzilla)
Per comment 0 and comment 6, clear NI.

> [8.Note]:
> The .vcf file in message shows normally when user adds the contact
> attachment by sharing contact in contact app.
Flags: needinfo?(lixia)
Comment on attachment 8675562 [details] [review]
[gaia] zbraniecki:1215471-fix-a-regression-introduced-by-patch-from-bug-1212151 > mozilla-b2g:master

Stealing review.
Attachment #8675562 - Flags: review?(borja.bugzilla) → review?(francisco)
Comment on attachment 8675562 [details] [review]
[gaia] zbraniecki:1215471-fix-a-regression-introduced-by-patch-from-bug-1212151 > mozilla-b2g:master

Thanks for the follow up, I tested on the phone and working great.

Also checked that we don't have any more calls to VcardFilename expecting a sync value.
Attachment #8675562 - Flags: review?(francisco) → review+
Comment on attachment 8675562 [details] [review]
[gaia] zbraniecki:1215471-fix-a-regression-introduced-by-patch-from-bug-1212151 > mozilla-b2g:master

Oh, sorry,

just run the unit test in my computer and seems we will need to modify one, to make it asynchronous, here is the error:

1) [communications-contacts/test/unit/contacts_activities_test.js] Test Activities Pick activity handling text/vcard, 1 result:
     Error: timeout of 10000ms exceeded
      at (anonymous) (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:3680:14)
      at run (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:3679:20)
      at runTest (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:4081:5)
      at (anonymous) (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:4127:7)
      at next (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:4007:1)
      at (anonymous) (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:4016:7)
      at next (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:3964:1)
      at (anonymous) (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:3979:7)
      at done (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:3700:5)
      at (anonymous) (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:3712:9)
      at (anonymous) (app://communications.gaiamobile.org/common/test/mocha_generators.js:46:20)
      at wrapper (app://communications.gaiamobile.org/common/test/mocha_generators.js:73:15)
      at run (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:3709:7)
      at (anonymous) (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:4929:1)
      at (anonymous) (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:4918:21)
      at (anonymous) (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:1:3)
Attachment #8675562 - Flags: review+
Comment on attachment 8675562 [details] [review]
[gaia] zbraniecki:1215471-fix-a-regression-introduced-by-patch-from-bug-1212151 > mozilla-b2g:master

Haha, actually it was the opposite. I fixed the test when I landed the ./shared patch to handle Promise without fixing the activity.js code.

So now, all I had to do was remove the explicit dealing with the Promise in the test :)

It's fixed now and the try should be green.
Attachment #8675562 - Flags: review?(francisco)
Comment on attachment 8675562 [details] [review]
[gaia] zbraniecki:1215471-fix-a-regression-introduced-by-patch-from-bug-1212151 > mozilla-b2g:master

Now this is looking great! Thanks a lot for the quick changes.
Attachment #8675562 - Flags: review?(francisco) → review+
Commit: https://github.com/mozilla-b2g/gaia/commit/caaf66334c2d76e2ae9e992d41dac2ce3cc76ae8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
See Also: → 1216183
Pushed to the nga branch to keep compatibility:

cfcaa1d
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: When user attaches a contact in Messages, the ".vcf" attachment shows normally. And "View/Remove attachment/Replace attachment" option menu will pop up when user taps on it. 
See attachment: verified_Aries_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20151020150236
Gaia Revision          11eb5d4cb2675d359d277ae17772bc75f7ccedbc
Gaia Date              2015-10-20 16:22:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f397034950304b845175f8dab8fccbdd0e8bf995
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151020.182846
Firmware Date          Tue Oct 20 18:28:58 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151020225607
Gaia Revision          11eb5d4cb2675d359d277ae17772bc75f7ccedbc
Gaia Date              2015-10-20 16:22:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f397034950304b845175f8dab8fccbdd0e8bf995
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151020.221418
Firmware Date          Tue Oct 20 22:14:26 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.