Disable unused project branches

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: catlee, Assigned: kmoir)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

2 years ago
We need to free up builders for the upcoming 2.5 branch in b2g, and for more test builders.

We can disable maple to start with.

Comment 1

2 years ago
Could we disable alder to a minimal amount of builders? I don't expect a lot of BBB development happening for now.

We could perhaps ask rail to also move from Date to Ash since you and nthomas are already sharing it :)

cypress has no activity since August.
holly has no activity since July.
(Assignee)

Comment 2

2 years ago
Created attachment 8674935 [details] [diff] [review]
bug1215527.patch

remove maple builders
(Assignee)

Comment 3

2 years ago
Created attachment 8674937 [details]
bug1215527builder.diff

builder diff
(Assignee)

Updated

2 years ago
Attachment #8674935 - Flags: review?(catlee)
(Reporter)

Updated

2 years ago
Attachment #8674935 - Flags: review?(catlee) → review+
(Reporter)

Comment 4

2 years ago
Just confirmed with :billm that we can retire holly as well.
(Assignee)

Updated

2 years ago
Attachment #8674935 - Flags: checked-in+
(Assignee)

Comment 5

2 years ago
Created attachment 8675049 [details] [diff] [review]
bug1215527bustage.patch

fixed bustage because b2g test builders were still enabled
Attachment #8675049 - Flags: checked-in+
(Assignee)

Comment 6

2 years ago
Created attachment 8675050 [details] [diff] [review]
bug1215527holly.patch

disable builds + tests on holly
(Assignee)

Comment 7

2 years ago
Created attachment 8675051 [details]
bug1215527hollybuilder.diff

builder diff for removing holly jobs on a linux test master
(Assignee)

Comment 8

2 years ago
Created attachment 8675057 [details]
bug1215527hollybuilder2.diff

builder diff for build master
(Assignee)

Updated

2 years ago
Assignee: nobody → kmoir
(Assignee)

Comment 9

2 years ago
Comment on attachment 8675050 [details] [diff] [review]
bug1215527holly.patch

I also ran test-masters.sh and it was green
Attachment #8675050 - Flags: review?(catlee)
(Reporter)

Comment 10

2 years ago
Comment on attachment 8675050 [details] [diff] [review]
bug1215527holly.patch

Review of attachment 8675050 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla-tests/config.py
@@ +2423,5 @@
>  # Fix this to a certain gecko version once e10s starts riding the trains
>  # Bug 1200437 - Use 7 chunks for m-e10-bc on branches > trunk, excluding twigs, 3 chunks elsewhere
>  aurora_gecko_version = BRANCHES['mozilla-aurora']['gecko_version']
>  trunk_gecko_version = BRANCHES['mozilla-central']['gecko_version']
> +for name, branch in items_at_least(BRANCHES, 'gecko_version', aurora_gecko_version):  

trim the trailing whitespace here please!
Attachment #8675050 - Flags: review?(catlee) → review+
(Assignee)

Comment 11

2 years ago
Comment on attachment 8675050 [details] [diff] [review]
bug1215527holly.patch

fixed whitespace
(Assignee)

Comment 12

2 years ago
Created attachment 8675110 [details] [diff] [review]
bug1215527tools.patch

had to remove maple and holly from production-branches.json too
Attachment #8675110 - Flags: checked-in+
(Assignee)

Comment 13

2 years ago
In production with this morning's reconfig
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Blocks: 1216531
You need to log in before you can comment on or make changes to this bug.