Segfault on mozilla-central tip when using nonexistant proxies

RESOLVED DUPLICATE of bug 1214200

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 1214200
2 years ago
2 years ago

People

(Reporter: manishearth, Unassigned)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(firefox44 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8675229 [details]
Backtrace

STR:

 - Prefs>Advanced>Network, set a random nonexistant HTTP proxy (ensure that you set a port).
 - Open websites. Firefox will crash.

Top of backtrace (full bt attached):


#0  0x00007fffe8af9bfc in fetch_sub (__m=std::memory_order_seq_cst, __i=1, this=this@entry=0x8)
    at /usr/include/c++/4.9/bits/atomic_base.h:628
#1  sub (aVal=1, aPtr=...) at ../../dist/include/mozilla/Atomics.h:259
#2  dec (aPtr=...) at ../../dist/include/mozilla/Atomics.h:291
#3  mozilla::detail::AtomicBaseIncDec<unsigned long, (mozilla::MemoryOrdering)2>::operator-- (this=this@entry=0x8)
    at ../../dist/include/mozilla/Atomics.h:565
#4  0x00007fffe8b88710 in operator-- (this=0x8) at ../../dist/include/nsISupportsImpl.h:353
#5  nsProxyInfo::Release (this=0x0) at /home/manishearth/Mozilla/mozilla-central/netwerk/base/nsProxyInfo.cpp:11
#6  0x00007fffe8b88983 in nsProtocolProxyService::PruneProxyInfo (this=0x7fffdb71f600, info=..., 
    list=0x7fffffff99d0) at /home/manishearth/Mozilla/mozilla-central/netwerk/base/nsProtocolProxyService.cpp:2011
#7  0x00007fffe8b88b5e in nsProtocolProxyService::ApplyFilters (this=0x7fffdb71f600, channel=0x7fffccdffa50, 
    info=..., list=0x7fffffff99d0)
    at /home/manishearth/Mozilla/mozilla-central/netwerk/base/nsProtocolProxyService.cpp:1930
#8  0x00007fffe8b8ebe0 in nsProtocolProxyService::ApplyFilters (this=<optimized out>, channel=<optimized out>, 
    info=..., proxyInfo=...) at /home/manishearth/Mozilla/mozilla-central/netwerk/base/nsProtocolProxyService.h:253
#9  0x00007fffe8b8bdf5 in nsProtocolProxyService::AsyncResolveInternal (this=0x7fffdb71f600, 
    channel=0x7fffccdffa50, flags=0, callback=0x7fffffff9a30, result=0x7fffccdffed0, isSyncOK=5)
    at /home/manishearth/Mozilla/mozilla-central/netwerk/base/nsProtocolProxyService.cpp:1273


I had been editing nsProtocolProxyService.cpp, but I did an hg qpop, and a clean (not even clobber, deleted the objdir) build of nightly and it still happens.
(Reporter)

Updated

2 years ago
Keywords: crash
(Reporter)

Updated

2 years ago
Summary: Segfault on mozilla-central tip when using proxies → Segfault on mozilla-central tip when using nonexistant proxies
(Reporter)

Comment 1

2 years ago
This happens on the downloadable nightly too. I'm on linux.
(Reporter)

Comment 2

2 years ago
The nightly was from

20151016030228
https://hg.mozilla.org/mozilla-central/rev/d374d16cbb251c9dac5af69f8e186e821ce82fe2
(Reporter)

Comment 3

2 years ago
:capella verified that the same thing crashes on his machine too (nightly build).

Bogus proxy needs to be something like `foo.bar`, just setting a random IP address won't work.


20151013030225
https://hg.mozilla.org/mozilla-central/rev/607a236c229994df99766c005f9ec729532d7747

is another crashing nightly

20150929102827
https://hg.mozilla.org/mozilla-central/rev/ccee6614fd9d18a31f263fbcfe9676b224d851aa


isn't.

I'm going to bisect.
(Reporter)

Comment 4

2 years ago
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015-10-12-03-06-12-mozilla-central/firefox-44.0a1.en-US.linux-x86_64.tar.bz2
20151012030612
https://hg.mozilla.org/mozilla-central/rev/0b69d304f861d0038fb78f1d52b0f5d13ef7c6fe


is the earliest crashing nightly. This seems to have been caused by bug 1121800.
(Reporter)

Updated

2 years ago
Depends on: 1121800
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1214200
You need to log in before you can comment on or make changes to this bug.