When a page closes the last open tab, Firefox window gets stuck with 0 tabs

RESOLVED DUPLICATE of bug 1238032

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1238032
3 years ago
2 years ago

People

(Reporter: Zac Campbell, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8675352 [details]
firefox_orphaned_window.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151012151721

Steps to reproduce:

1. Open a google spreadsheet which has a script editor project associated with it.
2. Open the script editor for the googlesheet (which will open in an adjacent tab).
3. Close all tabs aside from the two googlesheet tabs.
4. Close the googlesheet tab (not the script editor tab).


Actual results:

When the googlesheet tab is closed, it closes its associated script editor tab. This is fine when there are more than 2 tabs open, but when these are the last two tabs, the Firefox window gets stuck with 0 tabs and just the + (new tab) button. 
However the + and the address bar do not work, ctrl-t does not work; the window cannot be 'recovered' into a usable state.

If you have more than one window open, closing the stuck window will try to close the other remaining window.


Expected results:

It should probably close the whole window like clicking (x) on the last remaining tab of a window. Any other behaviour (eg spawning a fresh tab with about:home) would be inconsistent with this existing last-tab-closing behaviour.

Comment 1

3 years ago
Are you using any add-on that can cause this ?? to make sure, try starting firefox in safe mode and let us know what happens. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
QA Whiteboard: [bugday-20151012]
Component: Untriaged → Tabbed Browser
(Reporter)

Comment 2

3 years ago
I have a couple of add-ons but they're not causing this problem as it's replicable in safe mode. Were you unable to replicate it?

Comment 3

3 years ago
Nope, as a matter of fact, I already faced this previously but forgot to report, Now I have reported it on bug 1215895

btw, if you are facing this on safe mode, then it deserves a consideration of fixing :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → bug 1215895

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1238032
You need to log in before you can comment on or make changes to this bug.