[Pin the Web]User can't collapse/expand URL bar via scrolling page after Unpin site.

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: xiongfuchao, Assigned: rakhavan)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 disabled, b2g-master affected)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

Created attachment 8675595 [details]
logcat_0546.txt

[1.Description]:
[AriesKK v2.5][Pin the Web]When user unpins a browsing site from homescreen then fresh website, they will find they still can't collapse/expand url bar via scrolling page.
Found time:05:46
See attachment:Arieskk_v2.5.3gp & logcat_0546.txt


[2.Testing Steps]: 
Prerequisite: Exist a pinned site  
1. Open a page which is under the pinned site 
2. Go to homescreen to remove the pinned site 
3. Go back to the window opened at step 1 and refresh it 

[3.Expected Result]: 
3.The URL bar is expanded and user is able to collapse/expand via scrolling page.

[4.Actual Result]: 
3.URL bar is collapsed and user can't collapse/expand via scrolling page.

[5.Reproduction build]: 
AriesKK v2.5(Affected)
Build ID               20151018193102
Gaia Revision          f75a7e01912cee313fed92ff2089586f507b2ba5
Gaia Date              2015-10-16 13:00:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1a89632277fbaaf470c90a35573776048988f2d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151018.185054
Firmware Date          Sun Oct 18 18:51:02 UTC 2015
Bootloader             s1

FlameKK v2.5(Affected)
Build ID               20151015150343
Gaia Revision          8ea9029190af2ffeb04dcd97b323738125e31a0e
Gaia Date              2015-10-15 14:30:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d374d16cbb251c9dac5af69f8e186e821ce82fe2
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151015.183044
Firmware Date          Thu Oct 15 18:30:54 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
16811
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → disabled
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
Created attachment 8675599 [details]
AriesKK_v2.5.3gp
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Whiteboard: [systemsfe]
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
This works for me, can QA confirm it has been resolved?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: qawanted, verifyme
Resolution: --- → WORKSFORME
I am able to repro this issue on the Flame 2.5. When Pinning the website to the home screen, be sure to select the bottom pin option in order to add the site as a URL. Additionally, before opening up the pinned site in Step 1 be sure that link is not already running in task manager.  

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (319mb)
BuildID: 20151019030208
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: 1a157155a4fe0074b3d03b54fe9e466472c2cd56
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

--------------

This issue is NOT occuring on the Aries 2.5
Result: URL bar can be collapsed and expanded.

Environmental Variables:
Device: Aries 2.5 Kk
BuildID: 20151019104907
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: d3e87bb40753327550143ba8ac8ee27b300cd4a9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
I am seeing this issue occur on the Flame 2.5.

Result: After pinning the web URL to the homescreen and opening the link from there the URL will not be able to be collapsed or expanded. I believe steps 2 and 3 do not apply to this.

Environmental Variables:
Device: Flame 2.5 Kk Shallowflash (319mb)
BuildID: 20151019104541
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: 1a157155a4fe0074b3d03b54fe9e466472c2cd56
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Ben this issue still occurs on Flame.
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(bfrancis)
Keywords: verifyme
Resolution: WORKSFORME → ---
(Assignee)

Updated

3 years ago
Assignee: nobody → rakhavan
Created attachment 8676529 [details] [review]
[gaia] jedireza:unpin-collapse-expand-url-bar > mozilla-b2g:master

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Pin the Web]
(Assignee)

Comment 8

3 years ago
Comment on attachment 8676529 [details] [review]
[gaia] jedireza:unpin-collapse-expand-url-bar > mozilla-b2g:master

While debugging I noticed there wasn't a `scrollable` property on `this.app.config` but there was one on `this.app.chrome`. I tested my fix and it resolves the symptoms described in the STR.

Tests are passing [1], Gij4 failed at first but passed after I restarted the job.

[1] https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=98a5a51c608e92420006b3e92d4820a82b6310c4
Attachment #8676529 - Flags: review?(bfrancis)
Is this fixed by bug 1215911?
Flags: needinfo?(bfrancis) → needinfo?(rakhavan)
(Assignee)

Comment 10

3 years ago
Looks like this got fixed with bug 1215911.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(rakhavan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1215911

Comment 11

3 years ago
Verified on

[Flame]
Build ID               20151022003617
Gaia Revision          1b902ff26547e2a6c896351a6a73b673f65e19b2
Gaia Date              2015-10-21 14:56:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/daa7d98525e859d32a3b3e97101e129a897192a1
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151021.235526
Firmware Date          Wed Oct 21 23:55:35 UTC 2015
Bootloader             L1TC000118D0

[Aries]
Build ID               20151022003511
Gaia Revision          1b902ff26547e2a6c896351a6a73b673f65e19b2
Gaia Date              2015-10-21 14:56:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/daa7d98525e859d32a3b3e97101e129a897192a1
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151021.235445
Firmware Date          Wed Oct 21 23:54:53 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
Resolution: DUPLICATE → FIXED
Attachment #8676529 - Flags: review?(bfrancis)
You need to log in before you can comment on or make changes to this bug.