Closed Bug 1216186 Opened 7 years ago Closed 2 years ago

Chromium and Canary bookmarks are imported into "From Google Chrome" on non-startup migration

Categories

(Firefox :: Migration, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 74
Tracking Status
firefox42 --- wontfix
firefox43 --- wontfix
firefox44 --- wontfix
firefox74 + verified

People

(Reporter: MattN, Assigned: MattN)

References

()

Details

Attachments

(1 file)

There are two hard-coded instances of
> yield MigrationUtils.createImportedBookmarksFolder("Chrome", parentGuid);
which should have the actual source name (Chromium/Canary) passed instead of hard-coding "Chrome".

Reported in bug 706973 comment 18.
Flags: firefox-backlog+
Flags: qe-verify+
QA Contact: vasilica.mihasca
I sort of disagree on Canary, it's still Chrome, just a different update channel. I don't think other browsers would care about "Aurora" or "Nightly", for the final user it'd still be Firefox.
Duplicate of this bug: 1605882

This also affects the new Chromium Edge migrator where the issue is much worse.

Blocks: 1605491
Priority: -- → P2
Blocks: 1608513

[Tracking Requested - why for this release]: Microsoft Edge (Beta) migrator will import into "Google Chrome" bookmark folders.

Using _getLocalePropertyForBrowser isn't ideal but ideally this patch would get uplifted so I didn't want to do a larger refactoring to fix this.

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/9fec5e6b746f
Use the actual browser name for imported bookmark folders from Chromium. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74

I have attempted verification of this implementation with the information provided here (https://bugzilla.mozilla.org/show_bug.cgi?id=706973#c18) on Nightly v74.0a1 from 2020-01-31 and these are my results:

  • Windows 10: The folders of imported bookmarks are named "From Google Chrome", "From Google Chrome Canary" and "From Chromium".
  • Mac OS 10.14.6: The folders of imported bookmarks are named: "From Google Chrome", "From Google Chrome Canary".
    • Issue 1: The "Other bookmarks" are not being imported from Google Chrome to Nightly.
    • Issue 2: No Bookmarks are being imported from Chromium to Nightly.
  • Ubuntu 18.04: The folders of imported bookmarks are named: "From Google Chrome" and "From Chromium".
    • Note: There is no Google Chrome Canary supported for Linux.

This issue appears to be fixed in all OSes.

If the bookmarks are being imported, they are being put into folders with correct names, however, it appears there are situations where bookmarks are NOT being imported in the first place. Should I log these as new bugs or is it somewhat intended? I could not find logged bugs for them.

Status: RESOLVED → VERIFIED
Flags: qe-verify+ → needinfo?(MattN+bmo)

(In reply to Bodea Daniel [:danibodea] from comment #8)

Should I log these as new bugs or is it somewhat intended? I could not find logged bugs for them.

It's news to me so it would be great if you can file.

Flags: needinfo?(MattN+bmo)

I have retested importing the bookmarks form Google Chrome, Google Canary and Chromium.

Considering the first issue mentioned in comment 8, it seems that I might have not noticed them because they are not being imported into the "Other Bookmarks" folder, but into the "Bookmarks Menu" folder. Should this be considered an issue?

Considering the second issue mentioned, I was mistaking. For some reason, I could not reproduce that anymore.

Sorry about the back-and-forward, Matt!

Flags: needinfo?(MattN+bmo)

(In reply to Bodea Daniel [:danibodea] from comment #10)

Considering the first issue mentioned in comment 8, it seems that I might have not noticed them because they are not being imported into the "Other Bookmarks" folder, but into the "Bookmarks Menu" folder. Should this be considered an issue?

The behaviour you saw is expected.

Flags: needinfo?(MattN+bmo)
You need to log in before you can comment on or make changes to this bug.