Closed Bug 1608513 Opened 3 years ago Closed 3 years ago

Import from Microsoft's Chromium Edge browser

Categories

(Firefox :: Migration, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 74
Tracking Status
relnote-firefox --- 74+
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- verified

People

(Reporter: MattN, Assigned: MattN)

References

(Depends on 1 open bug)

Details

User Story

* Reading list items from the old Edge migrated to the "Reading List Saves" bookmark subfolder AFAICT.
* Win10 Profile path (Default user): `C:\Users\username\AppData\Local\Microsoft\Edge\User Data\Default`
* Users/Administrators can enable side-by-side (SxS) mode to continue to acess "Microsoft Edge Legacy": https://gpsearch.azurewebsites.net/#15096
** Unfortunately there is no difference in `Cc["@mozilla.org/uriloader/external-protocol-service;1"].getService(Ci.nsIExternalProtocolService).getApplicationDescription("http");` which still returns "Microsoft Edge".

Attachments

(1 file)

Bug 1605491 added support for the Beta channel, this bug will add support for the release channel. First we need to know what path the profile folder will use.

This is the non-beta version of the new Edge import that can maybe be added to the password manager test suite.

Flags: qe-verify+
Flags: needinfo?(aflorinescu)

The new Edge is released at https://microsoft.com/edge so I will figure out the paths.

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
User Story: (updated)

There's not an easy way to support all the possible configurations (Legacy Edge, side-by-side [SxS], and new Edge) on all Windows versions we support. I think the simplest path is to rename the legacy migrator to "Microsoft Edge Legacy" on all Windows versions. This may cause some confusion for users who are still migrating from it and don't have the Chromium Edge but I'm not sure addressing that is worth the complexity/time.

One thing that probably wouldn't be hard to implement would be hiding the legacy migrator when the application is hidden from the user. Unfortunately the registry key mentioned at https://docs.microsoft.com/en-us/deployedge/microsoft-edge-sysupdate-access-old-edge#how-operating-system-os-changes-are-triggered (SOFTWARE\Microsoft\EdgeUpdate\ClientState\{56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}\BrowserReplacement) doesn't exactly match the one set on my Windows 10 VM (HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate\ClientState\{56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}\BrowserReplacement) so I think we should ask Microsoft how best to detect when Microsoft Edge Legacy should be hidden. I can file a follow-up for this if you agree. What do you think Gijs?

User Story: (updated)
Flags: needinfo?(gijskruitbosch+bugs)
Depends on: 1216186

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #4)

There's not an easy way to support all the possible configurations (Legacy Edge, side-by-side [SxS], and new Edge) on all Windows versions we support. I think the simplest path is to rename the legacy migrator to "Microsoft Edge Legacy" on all Windows versions. This may cause some confusion for users who are still migrating from it and don't have the Chromium Edge but I'm not sure addressing that is worth the complexity/time.

One thing that probably wouldn't be hard to implement would be hiding the legacy migrator when the application is hidden from the user. Unfortunately the registry key mentioned at https://docs.microsoft.com/en-us/deployedge/microsoft-edge-sysupdate-access-old-edge#how-operating-system-os-changes-are-triggered (SOFTWARE\Microsoft\EdgeUpdate\ClientState\{56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}\BrowserReplacement) doesn't exactly match the one set on my Windows 10 VM (HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate\ClientState\{56EB18F8-B008-4CBD-B6D2-8C97FE7E9062}\BrowserReplacement) so I think we should ask Microsoft how best to detect when Microsoft Edge Legacy should be hidden. I can file a follow-up for this if you agree. What do you think Gijs?

Dealing with that in a follow-up is fine. Though I also wonder if we should just stop supporting the old version in a year or so (or if we detect a certain win10 version).

Flags: needinfo?(gijskruitbosch+bugs)
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/d686ead78b37
Chromium Edge migrator support on Windows and macOS. r=Gijs
Depends on: 1610985

(In reply to :Gijs (he/him) from comment #5)

Dealing with that in a follow-up is fine.

Filed bug 1610985.

Though I also wonder if we should just stop supporting the old version in a year or so (or if we detect a certain win10 version).

Maybe once we drop support for Windows 7. The Legacy Edge migrator is unlikely to be a maintenance burden though as I suspect it's unlikely to change after bug 1610985.

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74

I have managed to reproduce de issue on Fx 73.0a1(01-01-2020), I can confirm that the issue is fixed on Fx 74.0a1(31-01-2020).

Status: RESOLVED → VERIFIED

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #1)

This is the non-beta version of the new Edge import that can maybe be added to the password manager test suite.

done -> testrail

Flags: needinfo?(aflorinescu)

(In reply to Angela Lazar from comment #12)

https://support.mozilla.org/en-US/kb/import-bookmarks-internet-explorer-or-microsoft-edge

Thanks. Shouldn't step 3 have Edge mentioned?

Flags: needinfo?(anlazar)

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #13)

(In reply to Angela Lazar from comment #12)

https://support.mozilla.org/en-US/kb/import-bookmarks-internet-explorer-or-microsoft-edge

Thanks. Shouldn't step 3 have Edge mentioned?

Yes, good catch. Fixed.

Flags: needinfo?(anlazar)

Removing the relnote request until bug 1613337 is fixed :(

relnote-firefox: ? → ---

Release Note Request: See bug 1605491 comment #9.

relnote-firefox: --- → ?
Duplicate of this bug: 1557832
You need to log in before you can comment on or make changes to this bug.