Text and background with white color in alert box on Elementary OS.

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: williamoliveira2, Unassigned)

Tracking

43 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151019004047

Steps to reproduce:

Whenever you use the alert function.


Actual results:

Show text and background with white color.


Expected results:

The text must be legible.
Reporter

Updated

4 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Are you able to tell us please which GTK theme is in use?
Blocks: gtk3
Reporter

Comment 2

4 years ago
Elementary GTK theme, by default is light.
Without the dev edition theme there are a few other issues with white text on light backgrounds in other places, but I suspect about:robots is also affected with the dev edition theme.

Other places that have white text on a light background with the normal theme:
 - Input fields (url bar, search bar, bookmarks textfields, <input type="text"> etc.), both placeholders and actual input.

You can see almost all of that in my attached screenshot.
Looks like the MozFieldText is wrong here. I can see that too on FreyaOS.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Changes in bug 1219717 may have changed mozFieldText and will be in the next nightly.  Can you tell us, please whether that helps?
Yep, WFM as intended in Nightly version 45.0a1 (2015-11-03) under elementary OS Freya (0.3).
Great, thanks.
I'll dupe this to the bug where I think it was fixed, even though the symptoms reported there were different.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1219717
I still see this bug with GTK+ 3.16.7 and https://launchpad.net/egtk/4.x/4.0.6/+download/elementary.tar.xz

freaktechnik: I wonder what theme you are using.  Would you be able to link to somewhere I can view changes, please?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I am using the default theme of elementary OS Freya without any modification in version 4.0.6. From what I understand that should match the one you linked.

Is there any specific place you see this? It was all over the place as I described earlier in this bug.
I'm seeing the same as in attachment 8678074 [details] even with the theme from comment 10.
data:text/html,<input value="Hello"> reproduces.

Text is visible in the dark variant of the theme, as the background is different.
works for me on Ubuntu 16.04 in default theme (Ambiance) with Nightly 51.0a1, 20160823030224
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.