[gtk3, Ubuntu 12.04] URL/Search bars have wrong (dark) background

VERIFIED FIXED in Firefox 43

Status

()

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

({regression})

Trunk
mozilla45
All
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 verified, firefox44 verified, firefox45 verified, b2g-v2.5 fixed)

Details

Attachments

(3 attachments)

(Assignee)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1211892 +++

follow up from Bug 1211892 comment 17. We should use correct background for text fields (sMozFieldBackground/sMozFieldText).
(Assignee)

Updated

3 years ago
Blocks: 627699
(Assignee)

Comment 1

3 years ago
Created attachment 8680657 [details] [diff] [review]
background.patch

WIP patch. need to be tested on Ubuntu 12.04, works fine on Fedora/Gtk 3.18.
Comment on attachment 8680657 [details] [diff] [review]
background.patch

Thanks.  Feel free to land this as "use GtkTextView for text colors" or similar, even if you don't get a chance to test on Ubuntu 12.04, because it is the right thing to do.
Attachment #8680657 - Flags: review+
(Assignee)

Comment 3

3 years ago
Created attachment 8681335 [details]
ubuntu 12.04 with this patch

Ubuntu 12.04 looks fine with this patch. No big difference from Gtk2 version.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/95e4a598daf7
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Blocking bug 1193807 to indicate that we should uplift this before shipping the GTK3 build.
Blocks: 1193807
Assignee: nobody → stransky
Duplicate of this bug: 1216246
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
status-b2g-v2.5: fixed → ---
status-firefox43: --- → affected
Comment on attachment 8681348 [details] [diff] [review]
patch for check-in

Approval Request Comment
[Feature/regressing bug #]: bug 1186229
[User impact if declined]:
The effects of this can range from unhelpful background colors on older Ubuntu
distributions
(http://i.imgur.com/3yRWX0Z.png reported in bug 1211892 comment 7.)
to completely unreadable text in other themes, include defaults of other
distributions (bug 1216246).
[Describe test coverage new/current, TreeHerder]:
None.  Colors depend on themes.
[Risks and why]: 
Some risk of ending up with inappropriate colors in some untested themes, but
I confident that the logic here should give us colors that are consistent with
GTK in more situations.
[String/UUID change made/needed]:
None.
Attachment #8681348 - Flags: approval-mozilla-beta?
Attachment #8681348 - Flags: approval-mozilla-aurora?
Comment on attachment 8681348 [details] [diff] [review]
patch for check-in

Theme changes for readability with gtk3, ok to uplift to aurora and beta.
Attachment #8681348 - Flags: approval-mozilla-beta?
Attachment #8681348 - Flags: approval-mozilla-beta+
Attachment #8681348 - Flags: approval-mozilla-aurora?
Attachment #8681348 - Flags: approval-mozilla-aurora+

Comment 13

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/b883b0c1507c
status-firefox44: affected → fixed

Comment 14

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/a59d9d8978ad
status-firefox43: affected → fixed
Flags: qe-verify+
Reproduced the initial issue using an old Nightly build 2015-10-08, verified using Firefox 43 beta 3, latest Developer Edition 44.0a2 (Light Theme) and latest Nightly 45.0a1 on Ubuntu 12.04 32-bit.
Status: RESOLVED → VERIFIED
status-firefox43: fixed → verified
status-firefox44: fixed → verified
status-firefox45: fixed → verified
Flags: qe-verify+
Depends on: 1269749
You need to log in before you can comment on or make changes to this bug.