Closed Bug 1216366 Opened 6 years ago Closed 6 years ago

Black boxes since 2014-07-10 with e10s off and D3D11 OMTC HWA, D2D off

Categories

(Core :: Graphics, defect)

40 Branch
Unspecified
Windows
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla45
Tracking Status
e10s - ---
firefox41 --- wontfix
firefox42 --- wontfix
firefox43 --- affected
firefox44 --- affected
firefox45 --- fixed
firefox-esr38 --- affected

People

(Reporter: Oriol, Assigned: bas.schouten)

References

Details

(Keywords: regression)

Attachments

(2 files)

I got a bit confused by the various bugs we had on file for these issues. Does this still reproduce for you since bug 1211615 landed? If so, can you please narrow the regression range down with mozregression? I haven't been able to reproduce using the attached testcase personally.
Flags: needinfo?(oriol-bugzilla)
Yes, I can reproduce this on Win7 64-bit, nightly 2015-11-16.
I already used mozregression to get the regression range in comment 0.
Flags: needinfo?(oriol-bugzilla)
Thanks for confirming that this still reproduces. Disappointing, but good to know :)

The regression window from comment 0 is really confusing, though. It appears to be pointing at a b2g-inbound or fx-team change as the culprit, but nothing really stands out from those pushes that would appear to be a likely candidate. Can you please double-check that range to make sure it reliably comes back to that?

More specifically, if I widen the pushlog range you provided, I see a maybe-interesting push from Bas a bit further down: https://hg.mozilla.org/integration/mozilla-inbound/rev/51798e7d8abc (bug 1161815)

There's also https://hg.mozilla.org/integration/mozilla-inbound/rev/8985391fa24c (bug 1162179), but that seems unlikely since I'm pretty sure APZC wasn't enabled on Windows then.

If it helps, I can probably spin before/after builds from that range if we want to test either of those more specifically, though.
The regression range in comment 0 might be wrong. Moz-regression says the change is between 2015-05-06 and 2015-05-07 nightlies. Then it offers inbound builds but they are all OK. So I suspect it checks in the wrong inbound range.

But it doesn't matter. I have noticed that since gfx.blacklist.direct2d is not 4 by default, before 2015-05-07 there is no problem during the first run of a new profile. But it's switched automatically to 4, and that produces the issue on following runs, even before 2015-05-07.

Then, the regression range with gfx.blacklist.direct2d=4 is
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=196d05832e12&tochange=cb75d6cfb004

It seems there aren't inbound builds of that dates.
Summary: Black boxes since 2015-05-07 with e10s off and D3D11 OMTC HWA → Black boxes since 2014-07-10 with e10s off and D3D11 OMTC HWA
Adding 1217215 as related since both have same regression range.

It seems in my case I got the issue because Firefox detects unresolved driver issues with D2D, so it is automatically disabled through gfx.blacklist.direct2d=4.

I have another computer with Win10 where I couldn't reproduce the issue, but now I can with gfx.direct2d.disabled=true.
See Also: → 1217215
Summary: Black boxes since 2014-07-10 with e10s off and D3D11 OMTC HWA → Black boxes since 2014-07-10 with e10s off and D3D11 OMTC HWA, D2D off
Hey cool, I can reproduce too with Direct2D disabled :)

I'll try to bisect this locally.
Flags: needinfo?(ryanvm)
Local bisection confirms that this is a regression from bug 1035227.
Blocks: 1035227
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(ryanvm) → needinfo?(bas)
Assignee: nobody → bas
Flags: needinfo?(bas)
It's a little silly of me not to test this on D3D11 when I fixed the other two cases. I thought it would be included in BufferTextureHost. My apologies.
Attachment #8691230 - Flags: review?(nical.bugzilla)
Attachment #8691230 - Flags: review?(nical.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/ce1ab07ca576
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Can it be uplifted, like bug 1211615?
Flags: needinfo?(bas)
Flags: needinfo?(bas)
You need to log in before you can comment on or make changes to this bug.