Closed Bug 1216483 Opened 9 years ago Closed 6 months ago

[contenteditable] cursor movement between flexbox containers is incorrect

Categories

(Core :: Layout, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1475232

People

(Reporter: stef.busking, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20151015193503

Steps to reproduce:

See http://codepen.io/Bwrrp/pen/GpyrqQ for a minimal reproducable example.

The bug seems to be triggered by the use of flexbox layout inside a contenteditable element.

Place the text cursor on the last line of the first paragraph of text, then press the down arrow key to move to the second paragraph.


Actual results:

The cursor moves to (or close to) the end of the second paragraph, several lines of text below its previous position


Expected results:

The cursor should have moved to the line of text directly below its previous position, in a horizontally similar position. This does work correctly in Google Chrome.
OS: Unspecified → All
Hardware: Unspecified → All
Thanks for the bug report -- I can reproduce in latest Nightly, 44.0a1 (2015-10-19)
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Product: Firefox → Core
Version: 41 Branch → Trunk
Attached file testcase 1
Here's a slightly condensed version of the reporter's codepen testcase.
See Also: → 1475232
Severity: normal → S3

Checking back on some older issues I reported, it looks like I'm no longer able to reproduce this one in the latest Firefox Developer Edition (122.0b3). Feel free to close.

Thanks!

Here's the fix range (via mozregression)
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1712236ad4a08e07d74bfb03fef7fe2afeb1607a&tochange=08038e535f5829c597acade6b2b375bdb3615432

That includes the "see also" bug that was linked above -- bug 1475232 -- whose description sounds quite similar. So presumably this was fixed by that bug's patch. --> Duping.

Status: NEW → RESOLVED
Closed: 6 months ago
Duplicate of bug: 1475232
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: