[APZ] overflow: auto/scroll; would not scroll on scrollber by mouse wheel when apz enabled

RESOLVED FIXED in Firefox 44

Status

()

Core
Panning and Zooming
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: dvander)

Tracking

({regression})

44 Branch
mozilla44
Unspecified
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8676188 [details]
testcase

Build Identifier:
https://hg.mozilla.org/integration/mozilla-inbound/rev/da38bd42a863a6b3228500912a1bb2766ff79166
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0 ID:20151020024007

Steps To Reproduce:
1. Open attached testcase
2. mouse over scrollbar(not thumb) of Box1 and turn mouse wheel one tick
   --- may work as expected if no scrollbar on root element

3. mouse over scrollbar(not thumb) of Box2 and turn mouse wheel one tick
   --- does not work, BUG!!!

4. mouse over scrollbar(not thumb) of Box3 and turn mouse wheel one tick
   --- does not work, BUG!!!
   

Actual Results:
Not scroll the element.
However, It may work 2nd tick

Expected Results:
these elements should scroll properly

Bug 1190112 and Bug 1213324 did not fix the problem.
It works when disable APZ
Created attachment 8677099 [details] [diff] [review]
bug1216488.patch

Silly bug in the patch for bug 1213324 prevented this test case from being fixed too. We can't use NULL_SCROLL_ID to check whether we're building a scrollbar frame since that's used when the scrollframe isn't active.
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Attachment #8677099 - Flags: review?(tnikkel)
Attachment #8677099 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/mozilla-central/rev/24653ad483de
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox44: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
You need to log in before you can comment on or make changes to this bug.