Closed Bug 1216871 Opened 5 years ago Closed 5 years ago

crash in std::_Atomic_fetch_add_4(unsigned long volatile*, unsigned long, std::memory_order)

Categories

(Core :: Networking: HTTP, defect, critical)

44 Branch
x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1214200
Tracking Status
firefox44 --- affected

People

(Reporter: alex_mayorga, Assigned: bagder)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-57e16b61-a586-4f3d-a401-83dfe2151015.
=============================================================

Per https://crash-stats.mozilla.com/topcrasher/products/Firefox/versions/44.0a1 this is top crash #7 on Nightly this week.

Guessing a component from one of the signatures of the report I'm filing this from... Please correct me if I'm wrong =)

Crashing Thread
Frame 	Module 	Signature 	Source
0 	xul.dll 	std::_Atomic_fetch_add_4(unsigned long volatile*, unsigned long, std::memory_order) 	c:/tools/vs2013/vc/include/xatomic.h:1674
1 	xul.dll 	nsProxyInfo::Release() 	netwerk/base/nsProxyInfo.cpp
2 	xul.dll 	nsProtocolProxyService::PruneProxyInfo(nsProtocolInfo const&, nsIProxyInfo**) 	netwerk/base/nsProtocolProxyService.cpp
3 	xul.dll 	nsProtocolProxyService::ApplyFilters(nsIChannel*, nsProtocolInfo const&, nsCOMPtr<nsIProxyInfo>&) 	netwerk/base/nsProtocolProxyService.h
4 	xul.dll 	nsAsyncResolveRequest::DoCallback() 	netwerk/base/nsProtocolProxyService.cpp
5 	xul.dll 	nsAsyncResolveRequest::OnQueryComplete(nsresult, nsCString const&, nsCString const&) 	netwerk/base/nsProtocolProxyService.cpp
6 	xul.dll 	ExecuteCallback::Run() 	netwerk/base/nsPACMan.cpp
7 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
8 	xul.dll 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
9 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
10 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
11 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
12 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
13 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
14 	xul.dll 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp
15 	xul.dll 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp
16 	xul.dll 	XREMain::XRE_main(int, char** const, nsXREAppData const*) 	toolkit/xre/nsAppRunner.cpp
17 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp
18 	firefox.exe 	do_main 	browser/app/nsBrowserApp.cpp
19 	firefox.exe 	NS_internal_main(int, char**) 	browser/app/nsBrowserApp.cpp
20 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
21 	firefox.exe 	__tmainCRTStartup 	f:/dd/vctools/crt/crtw32/startup/crt0.c:255
22 	kernel32.dll 	BaseThreadInitThunk 	
23 	ntdll.dll 	__RtlUserThreadStart 	
24 	ntdll.dll 	_RtlUserThreadStart
Assignee: nobody → daniel
Curiously enough it seems this only crashes like this on Windows while this proxy code is generic. While I continue reading code and rebuild my windows dev version, if anyone has a reliable STR I'm interested.
Is this just a dup of bug 1214200?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1214200
You need to log in before you can comment on or make changes to this bug.